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Welcome to Your First Tour of the E³.series User Interface 
 
By following the steps described below, you can familiarize yourself with the E³.series User Interface. 
This tour points out how simple and easy it is to work with E³.series. 
 
Please read the respective foreword to the individual chapters since they will help you perform the 
described actions. The subsequent chapters on E³.schematic, E³.panel, E³.cable and the Database 
Editor should be read in conjunction with this chapter. They were written as completely as possible, so 
information may be repeated, as required, in each of the chapters. 
 
This Guide uses standard terms for defining the mouse button operations, e.g. click means press and 
release the left mouse button, double-click for two clicks of the left mouse button, click and drag, 
means click and hold the left mouse button while you move the pointer, and right-click for a click of 
the right mouse button. 
 
Have fun with this introduction! 
 

Starting E³.series 

After installing E³.series, the E³.series icon will appear on your desktop.  
 
Double-click on the icon to start the application.  
 
                                                                                                                                                   
If the icon does not appear on your desktop, you can start E³.series with the command: 
Start → Program Files → Zuken → E3.series 2020 → E3.cable. 
 
The first time the program is started, the user interface will appear with the standard default settings.  
 
NOTE: VALID ONLY IF US ENGLISH DEFINED AS INSTALLATION LANGUAGE! 
 
To be able to access the subcircuits described in this introduction, the following must be configured: 
Switch to Database Editor mode by selecting the Tools → Start Database Editor Mode command in 
the main menu bar.  
Then specify the ‘Subcircuit’ path in the Settings (Tools → Settings → Configuration Database): 

 

 
 

When everything has been defined, exit Database Editor Mode by selecting the File → Exit command 
in the main menu bar. 
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Opening a New or Existing Project 

With E³.series, you always work within a project. A project can consist of any number of drawing 
sheets and additional documents, which are stored in a single file. 

  
To create a new project, use the command 

File → New or the corresponding icon     
 
 
To open an existing project, use the command 

File → Open or the corresponding icon  and then select a project. 
 
 
Note: The spelling of the main menu commands (e.g. FILE) depends on the application look defined 
in E³. (e.g. Microsoft Office 2013 – Gray). Depending on the style the menu commands are written in 
capital letters only or with capital initial letter (e.g. FILE and File).  
 
 
The user interface can be arranged or customized to fit your needs (i.e. to achieve the best possible 
working environment). User-defined settings regarding the user interface can automatically be loaded 
with every start of E³.series. 
 
Check the Save current workspace when closing application option under View -> Workspace 
Configurations…. The next time you restart E³.series, the user interface automatically returns to the 
settings that were last saved. Using the Restore button it is possible to restore the workspace last 
saved.  
 

 
 
 
You can, for example, close the Output Window or reposition a toolbar. To close a window, click on 

the close icon  in the window’s upper right-hand corner. 
 
 

To move a toolbar, simply click on the dotted vertical line  at the beginning of the toolbar and drag 
the toolbar to the desired position. 
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To open or close a toolbar, create a user-specific toolbar or to shift, insert or delete icons within a 
toolbar, use the command Tools → Customize... 
 

 
 
 You can reopen a closed window in the View menu. 
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To make it easier to precisely place symbols and create connections, E³.series provides the option of 
displaying a crosshair cursor and placement grid as well as the normal cursor. 

These can be activated with the icons  and .  
 

              
 
 
The Working Grid, Alternative Grid, as well as the View Grid can be defined independently from one 
another at any time in the Settings menu. 
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The E³.series User Interface 

E³.series is a pure Windows application that supports user functionality such as Drag & Drop and 
Copy & Paste. Many functions that you know about other Windows programs can be applied here. 
The complete documentation is available as online help and can be found by simply clicking on the 

Help icon  or selecting Help -> Contents from the main menu bar. 
 
Let us begin with the program's user interface. It consists of various windows that show different views 
of the drawings and the internal, object-oriented database: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The Project Window displays all of the project's sheets and devices in a tree structure. 
 

 The Workspace displays the project’s drawing sheets and other documents. 
 

 The Database Window shows the components and symbols of the database on which 
they are based. 

 

 The Output Window displays all messages and results. 
 

 The Preview Window allows you to graphically preview sheets and components/symbols. 
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More Windows 

Using the View menu in the main menu bar, it is possible to display the following table 
windows: 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
. 
 
 
 

 
 
 
 
  

Device Table      Cabling Table  
 
Lists all devices used in the project.   Lists all graphically connected connections. 

 

Pin Table     Sheet Table     Connection Table  
 
Lists all pins used in the project.  Lists all sheets used in the project.   Lists all connections in the project. 
 



 
 
 

 

8 

 

The Settings Menu 

The Settings menu is used to define various settings for E³.series. 
The command Tools → Settings can be selected in the main menu bar and is only available when a 
project is opened. 
Depending on the schematic type of the active sheet either the ‘Electric’ or ‘Fluid’ settings menu 
appears. Individual options for the two disciplines are handled separately and stored. These options 
are represented in the Settings menu by italic characters. 
 
 

 
 
 
The settings for electric and fluid can be called up separately: 
Tools → Electric Settings 
Tools → Fluid Settings 
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Defining the Database Structure 

Components, symbols and other objects used in E³.series are stored in a database. 
The E3 database structure can be easily defined. Some common structures are already defined.  
Right-click on the defined database name in the Database Window Component tab and select the 
Tree Structure command from the displayed context menu. 
 
Select the structure template Class-main+Class 
english in the Use Structure section of the displayed 
Database Tree Structure dialog and confirm with OK. 
 
Your component database is now hierarchically 
structured. The first level corresponds with the main 
class and the next level contains the corresponding 
English classes. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Afterwards, switch to the Database Window’s Symbols tab. Right-click on the defined database name 
and select the Tree Structure command from the displayed context menu. Select the structure 
template Schematictype+Class_english.  
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Locating Components 

You can locate components either directly in 
the Component Database Tree or search for 
them by entering or selecting specific 
component attributes. To search by 
attributes, the search system must first be 
configured. To do this, right-click in the upper 
gray area of the Database Window and select 
the Component Search Configuration... 
command. 
 
 
 
 
 
 
 
 
 
All available attributes in the component database will be listed on the left side and can be used as 
search criteria. The list on the right side shows which search criteria is used for the component search. 
 
Select the attributes 
COMPONENT NAME and 
SUPPLIER from the left side of 
the menu and transfer them to 
the right side using the arrow 

button .  
Confirm your configuration with 
OK. The Component Search 
Configuration dialog is closed.  
 
 
 
 
 
 
 
 
 
The defined fields appear above the 
tree structure in the Database Window. 
From now on, the components will be 
displayed in the Component Tree 
based on the entries entered in the 
search fields. 
 
Note: The attribute Component name 
defines the name of the component as 
it appears in the database. 
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Feel free to experiment with the functionality in E³.series. If you are not satisfied with the results, use 

the UNDO command (<Ctrl+Z> or the toolbar icon   ) to undo any actions. 
 
If you wish, you can save the current drawing state as is (File → Save or Save as... command or the 

 icon) and continue working on it at a later date. 
 
 

Mouse Button Settings 

When working with E³.series, we recommend using a three-button mouse. The mouse buttons are 
assigned the following functions: 
 

• Left mouse button (select, move and modify)  
 
o Select objects: Click on an element to select it. If you click on another element, that one 

becomes active and the previous one inactive. To select more than one element to be 
modified, hold down the Shift key and then left-click on each of the desired elements.  
 

o Select objects within an area: Hold down the left mouse button and drag the mouse to 
define a rectangular area. All objects within the area are selected when the mouse button is 
released. 
 

o Move objects: Left-click on an object and keep the mouse button pressed and move the 
object. Release the mouse button when the object appears at the desired position. If several 
objects need to be moved simultaneously, mark them as described above, click on one of the 
selected objects, and move all of them together.   
 

o Enlarge and reduce the size of graphic objects: Select the graphic and then click on one of 
the 'handles', hold down the mouse button and drag the 'handle' in the desired direction. 
Depending on the direction, the object is either enlarged or reduced in size. Additionally 
holding down the Shift key while dragging, maintains the aspect ratio. 

 

• Middle mouse button (zoom)  
Press the middle mouse button and, drag the pointer diagonally to create a rectangle. The area 
selected will be enlarged to fill the window.  
The wheel on your mouse allows you to dynamically zoom on the sheet. Press Ctrl and scroll 
upwards to zoom in on the area. If you scroll back, the current area will be zoomed out.  
 

• Right mouse button (context menu)  
Press the right mouse button to display a context menu. Apart from general commands, the 
bottom part of the menu contains the Properties… commands for the selected object. Context 
menus can also be displayed in the Project Window and the Database Window. Some examples 
can be found below. 
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Examples of Context Menus 

After opening a project as described above, right-click on the 
project name in the Project Window to display a context 
menu that contains all the commands available. 
 
For example, in the case of a new project, you can create a 
New Sheet....  
 
In the displayed sub-menu, you can press the OK button 
directly. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Note: Since the project is newly created, its project name is Untitled. E³.series creates a sheet in a 
new project depending on whether a corresponding file template is defined (Tools -> Settings -> 
General). Use this sheet, if available, or create a New Sheet… in the new project. 
 
 
 
 
Click in the upper portion of the Database Window to display 
a context menu. The user can configure the database here or 
select a new symbol/component database. 
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The following example shows the context menu for 
components and symbols from the database. 
The functions New Component and Edit switch the user to 
the Database Editor mode. The Database Editor will be 
described later in a separate chapter. 
 
The Component Properties command displays the selected 
component’s properties as defined in the database. 
 
 
 
 
 
 
 
 
 
 
 
 
Context menus adapt themselves dynamically to the 
object selected. If nothing is selected, the context 
menu displays the standard commands along with the 
Sheet Properties... command. 
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Browsing in the Project 

To browse through the project after opening a sheet, use the keys “page up” and “page down” to jump 
to the next sheet or the previous one. 
The new sheet is displayed in the window of the previous sheet. The “Pos1” key jumps to the first 
sheet in the project and the “End” key to the last one.  
 
Place the component 3RT10152AP02 from the class Electric – Main contactor 3-pole, AC on a 
sheet (see hint). Drag the component from the Database Window to the workspace or select the Place 
command from the component’s context menu. This contactor consists of four individual symbols and 
one model.  
The component will be adopted from the database into the project automatically and assigned a 
device designation.  
Next, place the remaining contactor symbols (coils and contacts) on the sheet. To do so, open the 
Device Tree in the Project Window and drag the symbols from the device tree onto the sheet. 
Symbols, which have not been placed, are displayed in yellow in the device tree, those already placed 
displayed in blue.  
 

 
 
Right-click on one of the pins. A context menu containing additional menu items appears. 
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In addition to the Sheet Properties… command, the 
Symbol Properties... and Device Properties… 
commands are available for the object whose pin was 
selected.  
The pin itself has Pin Properties…, which can then 
be accessed through this menu. 
 
Besides these properties, additional commands have 
been added that refer specifically to the current object 
selected. 
Context menus adapt themselves dynamically to all 
marked (selected) objects. 
 
Note: The term “device” is used to signify a 
component that has already been placed in the project 
and can be found in the Project Window, whereas a 
“component” is selected from the Database Window. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Select all the placed symbols by dragging a rectangle around them with the left mouse button. All of 
the elements inside the rectangle have now been selected. 
 
Call up the context menu by right-clicking on any of the marked objects. Only those commands and 
properties pertaining to all of the objects selected are found in the context menu.  
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The property menus (e.g. Text Properties, Device Properties, etc.) display only entries or settings that 
the selected objects have in common. If a change is made, it applies to all the objects. 
 
For example, all marked text can be assigned new properties using the Text Properties (Font, Font 
Style, Size, Color …). 
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Overview of the Toolbars 

 
The E³.series user interface contains toolbars that offer quick access to several functions. To execute 
a command, simply click on the appropriate toolbar icon. The functions apply to selected objects or 
objects of a certain type. 
 
 
The Standard toolbar contains the default functionality, such as New (new project), Open, Close, 
Save, Cut, Copy, Paste, Paste extended, Graphic format painter, Attribute format painter, Duplicate, 
Show Clipboards, Print, Help, Undo and Redo. 
 
 

 
 
The Text format toolbar contains functionality used for texts. 
 

 
 
 

New text can be inserted with the symbol .  The text will receive the default values defined in the 
toolbar above, Font Arial, Size 2.5 mm, Color Automatic and Font Style Normal (i.e. not bold, italic or 
underlined) and the alignment is left. 
 
 
The Graphic toolbar contains functions that can be used to create and modify the various graphic 
elements. 
 

 
 
The graphic elements are Lines, Polygons, Rectangles, Curves, Circles, Arcs, Arcs (3 points), Clouds, 
Dimensions and Running Dimensions. In the example above, the object receives the predefined 
settings: color Automatic, line width 0.1 mm and line style solid. 
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Additional properties for placed graphics, such as hatching, can be changed by right-clicking on the 
graphic and selecting the Graphic Properties… command in the context menu. Graphic objects can 
have predefined properties, which can be found in the Tools → Settings → Graphic. 
 
 
The Display toolbar allows the user to navigate within the circuit diagram, to select components and 
symbols, remove selections; and for displaying the grid, ruler and crosshairs cursor, as well as 
connect points and open line ends. 
 

 
 
 
The Connect toolbar is used to manipulate electrical connections. It contains commands for creating 
connection lines, and it helps modify (configure) the graphical connection lines. 
 

 
 
 

  Insert Connection: used to connect two pins. 

 Auto Route by selection: automatically connects two selected objects 

  Multi-Connection: creates multi-connection(s). 

  Insert Curve Connection: inserts curved connect lines. 

  Autoconnect Vertical: connects all of the pins vertically inside a rectangle. 

  Autoconnect Horizontal: connects all of the pins horizontally inside the rectangle. 

 Angle clockwise /Angle counterclockwise: Angles selected connection(s) clockwise or 
counterclockwise. 

  Generate Signals: The connection line is automatically assigned a system-generated 
signal when the button is pressed. 

 Use line properties of starting connect line: Adopts the parameters of an already 
existing graphic connect line when connecting to it. 

 
The display mode for connection lines can be defined in the toolbar. In this example, the following 
values are defined: color Automatic, line width 0.1mm and Line style solid. 
 
The other icons in the toolbar are used for displaying open conductor connections and deleting 
connection lines. 
 
Here is an overview of the commands used to place elements. The rest of the commands will be 
explained in the chapters regarding working with E³.cable and E³.panel. 
 
 

 Inserts a template symbol. The template symbol shows the contents of a connect line. The 
displayed contents depend on the attributes assigned to the connect line. 
 

  Inserts a field that can be assigned device designation, higher level assignment and location. 
Display of all device properties of devices within a field can be suppressed when identical with the 
properties of the field. 
 

  Places a dynamic symbol. A dynamic symbol is a box that can be assigned an item 
designation and pins. 
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  Places a block (E³.cable only). A block represents either a functional unit that is not specified 
in detail or an electronic circuit’s data. 
 

  Deletes symbols or components from the drawing sheet. While deleted from the drawing, they 
have not been deleted from the project and therefore, are designated as unplaced devices in the 
Project Window (indicated in yellow). To completely remove a symbol or component from the project, it 
must also be deleted from the Project Window. 
 
All commands, which are contained in the toolbars, can also be found in the main menu bar.  
Toolbars can be customized to fit your needs by using the Tools → Customize… command. 
 

Shortcut Keys 

Hotkeys are a series or combination of keyboard keys. Hotkeys 
allow quick execution of commands that are often used without 
navigating through menu trees. Commands, which can be 
activated by means of hotkeys, display the predefined hotkey 
definition to the right of the command name in their pull-down 
menus. 
The Settings menu, for example, can be accessed by using 
hotkey S, the Levels dialog by using hotkey L. 
 
 
 
Apart from the ESC key the configuration of existing shortcuts can be changed and new shortcuts can 
be defined for existing commands. 
 
Using Tools → Customize → Keyboard… new or additional shortcuts can be created or already 

existing ones modified.  
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Predefined shortcut keys in E³.series 

 
These shortcuts are defined in the E³ default application: 

 
 

Menu Command Shortcut 

 

File New CTRL+N 

File Open CTRL+O 

File Save CTRL+S 

File Save as F12 

File Print CTRL+P 

File Exit Alt+F4 

 

Edit Undo CTRL+Z / Alt+BACK 

Edit Redo CTRL+Y 

Edit Cut CTRL+X / SHIFT+DEL 

Edit Copy CTRL+C / CTRL+INS 

Edit Paste CTRL+V / SHIFT+INS 

Edit Paste extended CTRL+SHIFT+V 

Edit Duplicate CTRL+D 

Edit Move (Rotate) CTRL+M 

Edit  Delete DEL 

Edit Change signal on selected 
pins 

CTRL+W 

Edit Select all CTRL+A 

Edit Search F3 

Edit Reset Highlight SHIFT+F3 

 

View Zoom Z 

View Fit to Window O 

View Adjust Zoom J 

View Full Screen F11 

View Levels L 

View Refresh F5 

 

Insert Last symbol D 

Insert Dimension M 

Insert Text T 

Insert Connection C 

Insert Curve Connection B 

Insert Template Symbol / 

 

Tools Settings S 

 

Misc Input coordinates P 

Misc Rotate R 

Misc Rotate in any angle CTRL+T 

Misc Mirror X X 

Misc Mirror Y Y 

Misc Jump CTRL+J 

Misc Jump to tree CTRL+left mouse button 

Misc Help F1/SHIFT+? 

Misc Rename 
(not possible with all objects) 

F2 
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You should now be familiar with the basic operating procedures in E³.series. The following chapters 
describe user examples to offer more information in detail. 
 
 
 

Enjoy working with 
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Welcome to Your First Tour of E³.schematic  
- in Combination with E³.cable 

 
In this chapter we will introduce you to the main functions of E³ and show you how to create reliable 
circuit diagrams for electrical engineering projects.  
Please read through the respective forewords of the individual chapters, which will then allow you to 
perform the described actions. Information, pertaining to basic operations and the User Interface, can 
be found in the chapter The E³.series User Interface.  
At the end of the tour, you will have learned about the various functions of E³.schematic, which can 
then be applied to your design needs. 
 
Have fun with this introduction! 
 

Opening an Existing Project 

With E³.schematic, you always work within a project. A project can consist of any number of drawing 
sheets and additional documents, which are stored in a single file. 
 
To open the project, use the command 

File → Open or the corresponding icon  in the main menu bar and select the  
Cooling water pump.e3s project from the directory 
C:\Users\Public\Documents\Zuken\E3.series_2020\data\Pumpe\. 
Note: The folders “User”, “Public” and “Documents” are displayed in Windows Explorer with the 
language-specific names. The file path works with the English and user-defined language. 
 
Now define the project language: British English. 
Open the Tools → Settings → General → Language dialog and select British English as the first 
language. 
 

 
 
Next, you are going to add sheets, symbols, devices, subcircuits, texts and so on to the project. 
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Inserting a New Sheet in the Project 

Insert a new sheet at the beginning of section 03-Circuit diagram.  
 
Open the folder 03-Circuit diagram in the Project Window Sheet tab, right-click on sheet 8 and select 
the command New Sheet from the displayed context menu. The Insert New Sheet dialog appears. 
Enter 7 as the sheet name, =A1 as the higher level assignment, +S1.MP as the location and then 
select the sheet format DINA3_Electric.  
Check to make sure that you have selected Insert before and press OK.  
The new sheet 8=A1+S1.MP will be inserted into the tree structure before sheet 8 with the desired 
format. 
 
 

      
 
 
 
 
 
Different sheet formats (e.g. DIN, extra-wide, Ladder Diagram, etc.) with their unique size, layout and 
sheet header information can be stored in the database.  
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Entering Sheet Header Text 

Sheet headers contain information typically found in the drawing sheet’s margins, e.g. Drawing Title, 
Drawn by, Date, Revision, and so forth. The sheet headers are displayed in the Sheet Properties… 
menu, which can be called up with the context menu by right-clicking anywhere on the sheet. 
 
 
Modify the properties of the newly created sheet. 
Overwrite the attributes Name (1) and Name (2) with the texts Power Supply and Main Switch from 
the text database.  
The texts are entered at the predefined locations like defined in the sheet format. 
 
First delete the entry from Name (1). 

To use texts from the text database, double-click in the Name (1) entry field and press the  button 
to open the Translation Table dialog.  
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Enter the text “Power supply” in the British English column’s Filter field and then press RETURN. 

 
 
 
Select the text line from the filter results and press OK or double-click on the desired line. 

 
 
Note: The * character can be used as a wildcard. 
The wildcard * represents any number of characters. Wildcards in search expressions thus have a 
great impact on the search results. 

  
 
 
The text Power supply with its ID number 400 is transferred to the Name (1) attribute. The characters 
&# and ; include the ID. 
 

 
 
When leaving the entry field, the clear text ‘Power supply’ is displayed.  
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Now enter the text ‘main switch’ for the attribute Name (2) in the same manner. 
Check the entries: Higher level assignment should be =A1 and the Location +S1.MP. 

 

 
 
 

 



 
 
 

 

28 

 

Displaying Placement Help Lines 

 
It is possible to place subcircuits more easily using placement help lines, which can be switched “on” 
or “off” using the Levels dialog.  
It is also possible to assign names to the individual levels. To open the dialog, use the View --> 
Levels command or simply press the key L. 
 
In the following Level Menu, level 3 should now be activated. 
 
Possibility 1:  Check the box (clicking on it) 
 

 
 
Possibility 2:  Import a predefined file containing the information required.  

To do so, select the Read Configuration command and then the Placement grid 
ON_e.vis file from the directory ...\data\. 

 
 

 
Confirm your definitions by pressing OK. The Levels dialog is closed and help lines will appear on the 
sheet making it easier to place the subcircuits. 
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Using Predefined Subcircuits 

Predefined subcircuits are stored in the E³.schematic database. You can add these predefined 
subcircuits to your project. 
 
These subcircuits are located in the Electric– Sub-circuit folder in the database window. Click on a 
subcircuit’s name to see the subcircuit in the Preview window.  
 
 
First, select the subcircuit Supply_00 and drag it from the 
database window onto Sheet 7. The subcircuit is displayed 
at the cursor’s position and will be placed on the sheet after 
releasing the mouse button. Place the subcircuit so that the 
signal references end up on the help lines in the upper right-
hand corner. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Next, select the subcircuit FU-COMP_01 and place it so that the open connection points fall on the 3 
phase supply lines. 
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In E³.schematic, subcircuits are inserted intelligently into a drawing. This means that open connect 
points will be automatically connected to existing connection lines and the device designations, that 
are already contained in the subcircuit, will be checked and updated, as required, online – without 
delay! 
 
The system automatically recognizes connection cross-references and enters them. 
 
To select a complete subcircuit, left-click on a device of the subcircuit or right-click on a device to open 
the context menu. The subcircuit must not be selected. Then select the Select Group command from 
the displayed context menu.  
 
With subcircuits, a new circuit diagram can be created, that is checked and based on approved 
standards. 
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Assigning Symbols to Components 

E³.schematic supports both symbol-oriented as well as component-oriented work. 
 
What is a symbol? A symbol is a circuit element that can be assigned to an existing component. 
Symbols can be used in any combination in a device. Symbols can be assigned any text the user 
chooses. Only when the device is assigned to a defined component, the symbols inside the 
component will be checked and the symbol text (e.g. pin names) automatically adapted. 
 
What is a component? A component is simply a set of predefined symbols supplied with pin numbers. 
However, components can also be assigned part numbers, supplier names and so forth in the 
database. The advantage of using components is that the pin numbers are checked from the very 
beginning, which makes it impossible to overload a component (e.g. using more contacts than the 
relay has available) or to use incorrect symbols. 
 
The components and symbols used in the subcircuit Supply_00 are assigned corresponding 
component codes (article numbers). When you want to assign other component types, E³.schematic 
supports by only offering valid types from the database.  
 
Zoom in on the area where the Coil –Z1 is located.  
Open the context menu by right-clicking on the 
symbol and select the Device Properties… 
command.  
 
The Component section under the Device tab 
contains the component VLT2800-F1B. Click on the 
arrow in this field’s right-hand margin and a list of all 
component types from the database will appear that 
are compatible for the symbol used in this device.  
 

 
 
Select the component type VLT2800-MSpule and click OK. A message appears saying that some 
pins have new signals. The device -Z1 is now assigned the component type VLT2800-MSpule. If a 
parts list is created or a panel constructed, the correct component will be used automatically. 
 

You can also click on the field  instead of the arrow button. The Select Component menu 
appears. A list of all components is displayed as structured as in the database window. It is possible to 
search for a component using the same filter methods as in the database. It can easily be decided, 
using the component description, whether it is the appropriate component.  
 
The same procedure is carried out with the terminals of terminal strip –XT1.  
Click on terminal 1 of -XT1. The complete device is selected. Click again on terminal 1 to remove the 
selection from the complete device and select terminal 1 only. Press the Shift key and left-click on 
terminals 2 and 3. Open the Device Properties dialog and assign them the component type 
1608620000. Assign terminal 4 the type 1608630000 and terminal 5 the component type 1608670000.  
Instead of selecting a component type from the list, the number can also be entered directly. This may 
be quicker than searching through the list.   
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Creating Terminal Plans in E³.schematic 

E³.schematic can create terminal plans that are always up to date according to the schematic drawing 
When working on your drawing, the terminal plan is updated in real time. 
 
The terminal plan is inserted with the Insert → Terminal Plan... command from the main menu bar. 
 
In the menu, you can define several properties for the terminal plan, such as the sheet format, display 
type, page number to start with, and the terminal strip, for which the terminal plan is being created. 
 
If no terminal strip is entered, all terminal strips contained in the circuit diagram are listed in the 
terminal plan. 
 
It is also possible to define whether you want to reduce the number of terminals used by automatically 
placing the connections on both the internal and external sides (Autocompress), and what the criteria 
for generating the jumpers will be.  
 
Enter the sheet name 101, the sheet format A3-TPH_N, the display type (table symbol) TAB-H_N 
and the terminal strip –XT3. Also select the Pin name (ascending) option. Confirm your 

definitions with OK. 
 

 
 
 
After entering the information in the Terminal Plan menu, the terminal plan for the terminal strip –XT3 
will be generated for the first time. From now on, all modifications concerning this terminal strip, 
regardless of which window you are working in, will be updated immediately in all displays (circuit 
diagram, terminal plan and project window) – without having to press another key and without any 
delay. 
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Right-click anywhere on the sheet 101 and select the Sheet Properties... command from the 
displayed context menu. Overwrite the Name (1) attribute with Terminal Plan -XT3. Select the term 
Terminal Plan from the Translation Table. 
 

Then switch to the Document Type attribute and double-click in the field entry, click on the arrow 
and select 04-Terminal diagram from the drop-down list of the Entry field. Confirm with OK. 
The sheet is moved automatically to the 04-Terminal diagram folder. 
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Editing Areas, Placing Devices and Laying Connections 

 
Select the Project Window’s Sheet tab and open sheet 9 by clicking on 
the box located in front of it.  
 
 
Install an additional pump on this sheet. With regular working on a project, this can easily be 
accomplished by copying the second control pump and then connecting it. For training purposes, you 
will create one part by copying as well as placing and connecting the other parts manually. 
 
 
Mark the area, as shown in the figure, 
by dragging a rectangle around it with 
the left mouse button.  
When you have selected not all 
required or too many objects, you can 
adjust your selection by holding the 
Shift key and clicking on the respective 
objects that are either missing or 
selected by accident. 
 
Make sure you include the bushings 
from connector –X2S but not connector 
–X2P. Also copy the outgoing 
conductors on pins 1, 3 and 5 of the 
device -F4. 
 

Use the Copy icon   from the toolbar 
or the hotkey combination CTRL-C to 
copy the subcircuit. The selected 
elements are copied to the clipboard 
and can be pasted at another position. 
 
 
 
 

Place the copied part with the Paste icon  or CTRL-V onto the right side of the sheet. When 
copying as with pasting, E³. observes that no device designations are duplicated or that existing 
devices are crowded. 
 

Activate the Mark line end connect points button  in the toolbar to highlight open connect points in 
yellow. 
 
Rename the motor circuit switch –F10 to –F5 in the 
Device designation field of the Device Properties…. 
dialog displayed by right-clicking on the respective 
switch. 
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The missing connection lines must now be drawn. Electrical connections are treated as “intelligent” 
connections because each of the connections possesses various attributes.  
With manual connections, the corners are set automatically. Route connections (forced wiring 
connections), which are required for exact wiring representations can also be created just as quickly 
and easily. To see the different methods, create connections directly and others as “routes”.  
 

To draw several connections, double-click on the Insert Connection icon . A single click on the icon 
activates the connection mode for one connection only. Notice how the cursor’s shape changes.  
 
Position the cursor on the open line end of the 
motor circuit switch –F5. As soon as the cursor 
is positioned on a possible pin or connection 
line, its shape changes once again and the start 
point of the connection can be set. To do so, 
left click to start the connection. If corners are 
required in the connection, these can likewise 
be defined with a click of the mouse. However, 
E³. can automatically draw corners. 
 
As you move the mouse, you will notice the connection being drawn dynamically. If the cursor is 
positioned over a possible pin, its shape changes again and by clicking the mouse button, the 
connection will be closed.  
 
Now, move the cursor to the left to the existing 
corner point of the corresponding connection 
and close the connection by left-clicking. 
 
 
 
 
 
 
 
Because you are still in the Insert Connection mode, use the same procedure to draw the two 
remaining connection lines. Press the Esc key to terminate the connection mode.  
 
The rest of the missing connections will be drawn as “Route” connections. 
The module E³.panel, which is also used for the panel wiring, makes sure the wiring is defined 
correctly, even if the wiring sequence is not clear in 
the circuit diagram. 
Since the angled (skewed) connections do not lay in 
the 4 mm grid used so far, we must define the grid 
size as 2 mm in the so-called Alternative Grid 
(Tools --> Settings… --> General).  
 
This “second grid” is activated using the Ctrl key. 
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By default, connection lines are drawn at right angles. Sometimes, however, tapered connections are 
required. These can be creating by keeping the SHIFT key pressed while connecting.  
To draw these “route connections”, switch to the connection mode as described above. Click on the 
first open connection line of contactor –Q6, move the cursor to the left stopping shortly before you 
reach your objective -Q4, press the Ctrl key and click the left mouse button to mark the corner. While 
pressing the Ctrl key, also press the SHIFT key and position the cursor beneath the connection line. 
You will see the angled connection form, which can be closed by pressing the left mouse button once 
again. Follow the same procedure for the two remaining, open connections. 
 

 
 
 
We now have to place the third pump that is missing in our circuit. Open the Electric - Motor folder in 
the Database Window’s Component tab and select the component K21R-160-L8. Place the motor 
(the first element of the component) by dragging it to the desired location on the sheet, next to Pump 
2.  
As soon as an element is clicked on in the Database Window, it will also be displayed in the Preview 
Window to see whether you have found the right symbol.  
 
By placing any element of a component, the entire component will be loaded into the drawing and 
automatically receive a device designation (-M3).  
The devices used in your drawing, are listed in the Project Window’s Device tab. 
 
 

 
 
Using the Device Properties… menu, displayed by right-clicking on the motor, enter the text Pump 3 
for the attribute Function. This text will automatically appear underneath the motor symbol.  
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Connecting the Motor using a Cable 

To connect the motor using a cable, several steps need to be executed. The connectors on the motor 
side as well as on the panel side need to be placed.  The connect lines need to be drawn and the 
cable must be placed. Much of this work is done by E³.schematic. 
  
Since the appropriate mating connectors have already been defined for the motor and connectors in 
the database, these will be inserted automatically. Also, the connect lines do not have to be 
individually placed. Autoconnect within an area can be used to complete these connections. This 
command is used to automatically connect all connect points within a defined area, which have not yet 
been connected with one another. If connections already exist in the area, these will also be edited. 
 
First, create the connection. This command can be activated with Insert → Autoconnect → Inside 

Area Vertical or using the Autoconnect Vertical icon .  
 
 
Drag a rectangle around the connectors and the motor. After releasing the mouse button, the 
appropriate connectors and connection lines will be inserted.  
 
Next, adjust names and visibility of the texts. 
After all of the connectors have been inserted, select 
one of the contacts of connector –X2S, call up the 
Device Properties… from the context menu and 
change the Device designation of the connector –X2S 
to –X3S.  
 
Repeat this procedure for connector –X5 and change 
its Device designation to –X3P.  
 
Lastly, change the Device designation from the 
motor’s connector –X4 to –XS3.  
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Superfluous information should be removed from the drawing.  
 
Mark the last three contacts of connector –XS3 
(multi-select) and call up the Symbol 
Properties… menu, which displays the selected 
symbols’ text and attributes. Uncheck the check 
box in front of Device designation so that this 
text is not displayed. 
Additionally, deactivate the display of the text 
type Component code for the contacts 1-3. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Compare your drawing with the example! 
 

 
 
 
 
Now the conductors of an appropriate cable need to be assigned to the existing connection lines 
between the connectors.  
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Search for the appropriate cable in the Electric - Cable 
folder in the Component Database (Servo-700-4G2.5), 
select the conductors 1…GNYE and call up the Connect 
Conductors Continuously command in the cable’s context 
menu. 
 
Then drag the selected conductors over the previously 
created connect lines. To do so, left-click on the right side 
next to the connection line, move the cursor over the 
conductors to the left side and “set” the conductors by left-
clicking once again. 
 

 
 
 
Next right-click on a connect line and select the Jump to Tree command from the displayed context 
menu to jump to the respective cable in the Project window’s Devices tab.  
   

               
 
 
 
 
 
Select the cable –W1 (green icon) and call up the Device Properties menu from the displayed context 
menu. Change the cable’s Device designation to –W3, its Higher level assignment to =A1 and its 
Location to +Tank1. The algebraic signs (-, =, +) do not have to be entered, they are entered 
automatically. The cable is displayed with its new device name. 
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Because the cable’s letter code as well as the conductor name itself need to appear on the first 
conductor, the Symbol Properties need to be adjusted.  
 
Click on the first conductor’s template symbol on the sheet and select the Symbol Properties 
command from the context menu.  
Activate the corresponding checkbox and close the dialog.  
 
In addition to the conductor names, the cable (-W3) is now identified by its cable name in the drawing. 
 

       
 
 
 
 
 
 
 
 
 
 
 
 
It is easy to control the connections. To do so, right-click on any of the connections to the motor and 
select the Connection Properties command in the context menu. In this menu, you can view or 
change the connection properties. Clicking on the Cables/Conductors tab gives you an overview of 
the cable. In the tree structure view, you can see which conductor is connected to which 
component/pin. 
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Creating the Cable Drawing (E³.cable Functionality) 

This chapter offers a short look at cable documentation. The cable with its connected connectors is 
displayed in various views. E³.cable offers for example specialized functionality to create cable 
documentation. It is possible to create cable documentation for machinery or for cabling and 
displaying of harnesses. 
 
While E³.schematic enables the user to display each cable as a report containing various information, 
E³.cable can also graphically display the cable and its connectors in several, different views. 
E³.series’ object-oriented functionality is more advantageous to use since all modifications (as with 
the terminal plan) take effect immediately without any further updates. 
Next, we will create a cable drawing. 
 
Since the cable drawing requires its own sheet, we will have to create a new sheet. Open the 05-
Cable plan folder in the Project Window Sheet tab. Right-click on sheet 40 and select the New Sheet 
command. The new sheet will be named Sheet 41.  
 
Right-click anywhere on the sheet and call up the Sheet 
Properties... command from the displayed context menu. 
Adjust the Name (1) attribute to Cable plan –W3 and define 
=A1 as Higher level Assignment and +Tank1 as Location. 

 
 
 
 
 
 
 
 
The help lines on the sheet, which were previously switched on (section: Switching On the Placement 
Help Lines), are no longer necessary. They can be deactivated by clicking on the Symbol Graphics 
box on level 3 in the Levels menu. The menu can also be opened by using the hotkey L. 
 
We are going to use the cable –W3=A1+Tank1 that was created earlier to create a cable plan.  
 
Switch to the Project Window Devices tab and search for the cable named  
–W3=A1+Tank1. Select the command Place New Device View... in the cable’s context menu.  
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A menu allowing the user to select how the connector will be displayed in the new view now appears 
for each connector that is connected to the cable. In our example, there are two connectors but 
naturally, there can be several connectors connected to a cable/cable harness.  
 
For the first view, we want to place the 
complete connector.  
Select the Place as: complete device option. 
Select the HTS-HE-4-P010SV symbol from the 
Defined View Symbols and click on the Place 
button to close the menu. 
 
The selected symbol appears at the cursor 
position and can be placed on the sheet by 
moving the mouse to the desired position and 
clicking the left mouse button.  
Place the view in the upper left hand corner of 
the sheet. 
 
 
 
 
 
 
The menu for the cable’s next connector appears automatically upon placing the first one. 
 
Select the HTS-HE-4-S010SV symbol and close the menu with the Place command.  
 
Before placing the symbol, it needs to be mirrored on the Y-
axis. To do so, right-click and select the Mirror by Y-axis 
command in the context menu.  
You will notice that the symbol is now mirrored and can be 
placed using the left mouse button.  
Place the symbol in the upper right corner of the sheet. 
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All symbols, which appear in the Defined View Symbols list in the menu, are already defined in the 
database for the connector so that no mistake occurs when selecting. 
 
In addition to the complete connector view, we want to display the individual pins with their 
conductors. We are now going to call up a new view of the same cable -W3.  
Return to the Place New Device View...  menu, select W_ST as view symbol and select the Place 
as: single pins command.  
Place the first connector view underneath the left connector. Then select the view symbol W_BU for 
the second connector, mirror the second connector on the Y-axis before placing it underneath the right 
connector on the sheet. 
 
 
To see which cable conductors are connected to which connector pins, use the Conductor Logic Lines 

icon   . 
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In the third view of the cable, we will display the connectors as “Tables”. Open the Place New Device 
View...  menu of the cable -W3, select the symbol TABWIRE3 for both connectors. Remember to 
mirror the second connector table on its Y-axis. 
 
 

 
 
 
Different connector information is displayed automatically in the table. The output together with the 
symbol will be defined in the Symbol Database.  
In our example, the following information is 
output: 
the signal on the connector pin, the device’s 
pin name on the other side of the conductor, 
and the cable connected to the conductors 
with the cross-reference to the original 
connector pin. 
 
 
 
 
 
Draw a connect line between the complete connectors using the hotkey C. Since the connection line is 
going to display the entire cable, draw it somewhat thicker. Mark the line and change the line 
thickness to 2 mm using the Connect Line Width.  
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To identify which cable and conductors are used, place a template symbol on the connection line. The 
symbol itself defines the information that will be displayed.  
 
Switch to the Misc tab in the Database Window and place the symbol CabAndCoreName_hori from 
the Electric - Misc_Attribute text template folder on the connection line. The text can now be moved 
or the text height modified. 
 

       
                 

 
 
We also want to connect the individual pins and display the conductors. Select the Insert → 
Autoconnect → Inside Area Horizontal command from the Main Menu bar or use the corresponding 

symbol from the toolbar ,  and drag a rectangle around the pins to connect.  

Then double-click on the Insert Template Symbol icon  to activate the conductor indicator display 
mode. Place the conductors on the individual connections by dragging the cursor over the connect 
lines while pressing the left mouse button. To exit this mode, press the Esc key. 

 
 
 
Before we continue, switch off the Conductor Logic Lines display by deactivating the corresponding 

button in the toolbar  . 
 
In this way, it is possible to create error-free cable drawings. The advantage here is, like already 
explained at the beginning of the chapter, that modifications, regardless of where they are carried out, 
are automatically updated in all views.  
Information, which is required to produce a complete connector or cable harness, can be added in the 
project or to individual elements at any time, and used for reports, lists and interface files.  
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To see how the completed cable sheet should appear, open sheet 40 in our sample project. All cable 
wires are displayed along with their shielding, as well as any additional cable attributes that have been 
added.  
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Placing Additional Device Elements with Online Cross-References 

By inserting an additional pump and its controls on sheet 9, we also loaded two more contactors into 

the project, in addition to having already used some of the contacts.  
This specifically concerns the contactors –Q6 and –Q7, which were inserted when copying the 
subcircuit. We still have to connect the contactors’ coils. In this example, you will clearly see the online 
cross-references as well as a sampling of E³.schematic’s PLC functionality. 
 
Open sheet 13 in the 03-Circuit diagram folder in the Project Window Sheet tab by double-clicking on 
the sheet symbol or simply clicking on the box in front of the sheet symbol. The controls for the other 
“pump contactors” are located there. The new contactors need to be connected in the same way.  
 
Click on the “+” signs in front of both devices, –Q6 and –Q7, in the Project Window Device tab. You 
will see all of the symbols belonging to the respective devices. Those symbols, which have already 
been placed in the project, are displayed in blue and those that have not in yellow.  
 
Select the first two symbols (contact 
arrangement and coil) under each device with 
multi-select (click on the symbols to be selected 
while pressing the CTRL key) and then with a 
right-click, call up the context menu and select 
the Place One-by-One command.  
 
 
 
 
 
 
 
 
 
The symbols will appear one-by-one at the cursor position and can be placed as shown, next to the 
coil -Q5.  
 

 
 
Since you can only select and place elements that have not yet been placed with the command Place 
One-by-One, this will prevent you from using an element more than once. 
 
Coils and contact arrangements are defined as separate elements in the standard database. This 
allows them to be placed anywhere, either together or separately. You can, however, define the coil 
and contact arrangement as a single element in the database so that when you place one you also 
place the other.  
A motor protection switch is a classic example of “combined symbols”, in which the main contacts and 
cross-references to the auxiliary contacts are drawn as one symbol. 
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We are still missing both PLC outputs. These can be placed in the same way as the contactors -Q6 
and -Q7.  
 
To find the appropriate symbol easily in the Device Tree View, it will be displayed in the Preview 
Window as soon as it is selected. Additionally the pin names are displayed in brackets after the 
symbols. Hence you have a good overview over which element of a device you have chosen, without 
looking at the graphic.  
In our example the two PLC OUTPUT symbols of the device -A2.2 with the pin names 37 and 38 are 
selected.   
Select the two outputs, right-click and select the Place One-by-One command from the displayed 
context menu. Arrange the symbols according to the example above the coils.  
           

            
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
The addresses and functions are immediately entered for both outputs. The information contained in 
the PLC overview symbol is entered on sheet 11. The PLC functionality of E³.schematic allows this 
information to be transferred immediately to the input/output symbols. 
Changes to the PLC comments on the overview symbols are transferred online to the input or output 
symbols and vice versa. 
The PLC information can also be transferred to PLC programming devices as an assignment list or the 
information from the assignment list will be entered automatically for the correct PLC symbol in the 
plan. 
 
Cross-references between placed symbols are entered immediately in E³.schematic automatically. 
This applies to all symbols that are represented by several circuit diagram symbols, for example PLC 
symbols, individual symbols of a contactor or another device. The user can define how the cross-
references are arranged and between which symbols they appear. You see immediately on the 
contact arrangements, which contacts have already been placed on the contactors –Q6 and –Q7, and 
with the output symbols, where their overview symbols are located.  
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E³.schematic’s special navigational features allow you to directly “jump” to any location. Right-click on 
any cross-reference text and select the Jump to Schematic or Jump to Panel command. The sheet, 
to which the cross-reference refers, will be opened automatically and the symbol highlighted.  
Remove the highlighting with Shift+F3. 

 

 
 
It is also possible to move about (navigate) using the “Online-Parts List” in the Project Window’s 
Device tab. Double-click on any symbol in the tree structure, which has already been placed, and you 
will jump directly to that symbol. 
 

 
 
   
 
 
 
 
 
To complete our subcircuit, we must add the missing connection lines. Connect the symbols using the 
command Insert -> Autoconnect -> Inside Area. The command is similar to Autoconnect -> Inside 
Area Horizontal, which we used in the previous section.  
Note: Connections with corners cannot be created with Autoconnect. Thus, create the connection 
between -Q6 and -Q7 to -Q5 manually. Consider route connections! 
 
 
We must now add a contact, which is missing, to the contactor –Q7. Select the contact (pin numbers 
31 and 32) from the Device Tree and place it directly on the existing connection between the coil of  
–Q6 and the PLC output symbol with Drag & Drop. 
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Changing Attributes 

The contactors –Q6 and –Q7 were created by copying the devices –Q4 and –Q5 and as a result, also 
adopted their attributes. This is also true for their Function text. There are several, different ways to 
change the text.  
 
The attribute can either be modified in the Device tab of the Device Properties called up from the 
device’s context menu in the Device tree, or if attributes are displayed by texts in the drawing, these 
can easily be modified by using the Text Properties.  
 
For example, right-click on the text underneath the contact arrangement –Q7, select the Text 
Properties… command and enter the text Pump 3 main supply. This results in the attribute being 
changed directly. 
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In both cases, it is not the actual function 
text that is displayed, but the text’s 
wildcard, since this text is contained in the 
text database. F3 opens the Translation 
Table dialog accessing the text database, 
from where the desired texts can be 
selected. 
 
Texts placed through the text database 
are automatically translated when 
switching languages (Tools → Settings 
→ General → Language). Up to five 
languages can be defined. Additionally, 
the “language” Pictogram can be 
selected. 
 
When all texts (also comments) are 
entered through the text database, the 
complete drawing can quickly be switched 
to another language (or several languages) by one click. 
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Modifications to Existing Drawings 

It is crucial that the user is able to modify a drawing quickly, easily and reliably (proofed). 
With E³., changes are displayed instantly in all representations of an object. Checks can also be done 
to the views that are practical for the workflow. 
Connected components can be moved quickly and intelligently, also to other sheets.  
 
An example for modifications is moving connected symbols. 
 
Click on the right-hand PLC output symbol on sheet 13 and while 
pressing the left mouse button, move the symbol. You will notice 
that the connection line, connected to the symbol, moves 
automatically as well. This is also possible for symbols with several 
connections. When moving a symbol, E³. checks in real time to see 
whether the new position is allowed and if the connection line can 
be drawn without conflicting with any other elements. 
 
Note: The setting Tools -> Settings -> Connection -> Reconnect 
after deleting symbols defines what happens if a symbol is 
deleted from an existing connection. When the setting is active and 
the attributes assigned to both connections allow, the connection is 
automatically made. When the setting is inactive, the connections 
remain open. 
 
 
 
Delete a contact or coil on sheet 13 by first selecting the appropriate symbol and then pressing the Del 
key. The symbol will be deleted and the connection closed. To undo this delete procedure, use the 

UNDO command with either Ctrl+Z or the corresponding icon . 
 
 
Open sheet 16 in the 03-Circuit diagram folder to see the electrical drive for the directional gate valve 
–S1. Next, we want to place this valve in the hydraulics documentation on sheet Hydraulics/50 and 
complete it with the hydraulic connections. 
 
 
Open sheet 50. Switch to the Project Window Device tab and place the hydraulic symbol of valve –S1 
from within the tree via Drag & Drop or by right-clicking and selecting the Place command. 
Afterwards, create the valve connections. Compare your results with the figure. 
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The hydraulic valve symbol -S1=A1+BAZ1 displays 2 cross-references from which you can jump to 
the schematic documentation to the electrical drive for the valve coils. 
To do so, right-click on the cross-reference text +S1.MP/16.C3 and select the Jump to Schematic 
command from the displayed context menu. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Now, we need to have the motor–M2=A1+Tank1 displayed in the topology documentation with its 
insert position at the tank. E³.cable offers the possibility to place another view of the motor. 
 
Open sheet 2 in the 01-Topology folder, switch to the Project 
Window Device Tree, right-click on the motor–M2=A1+Tank1 
and select the Place New Device View command from the 
displayed context menu. Select View #2 as the Defined View 
Structure in the New View dialog. 
 

 
 

Place the view as shown:  
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The texts of the placed view can then be multi-selected and moved to the desired position. Right-click 
on the selected texts and select the Text Properties from the displayed context menu. Then select 
the Oval and Display subsidiary line to owner options in the Ballooning section. 
 

 
 
Compare your results with those here: 
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Modifications to the Terminal Plan 

The terminal plan in E³.schematic is an on-line document. Changes to the circuit diagram are updated 
immediately and automatically in the terminal plan. Correspondingly, all changes made to the terminal 
plan are immediately updated in all other representations of an object (circuit diagram, panel plan, 
device list, …). This functionality is described in the following paragraphs. 
 
Note: Online update of the terminal plan can be switched on and off with the Online update option in 
the Terminal plan section of Tools -> Settings -> Placement -> Terminal. 
 
Open the terminal plan on sheet 32 in the 04-Terminal plan folder. The format (table or graphic) can 
be defined when creating the terminal plan. The layout of the lines can also be user-defined. For this, 
corresponding template symbols exist in the symbol database.  
 
Enlarge the area at the top of the terminal plan so that you can read which components are connected 
to the terminal block. The sequence, in which the terminals appear in the terminal plan, is defined 
when first created. Otherwise, the sequence will be structured according to how the terminals are 
arranged in the Project Window’s Device tab.  
Also open the terminal block -XT2=A1+S1.MP in the Device tab.  
 

   
 
 
 
 
 
 
 
 
 
 
 
 

 
 
The first thing we want to do is to change the sequence of the terminals. As you can see in the 
terminal plan, the PLC =A1+S1.MP-A2.2 is connected to the terminals 12, 13 and 21. These 
terminals, which are connected to the PLC, can be easily placed side-by-side in the terminal plan.  
To do so, click on the line containing terminal 21 and while pressing the left mouse button, drag it 
under terminal 13. The terminal sequence is immediately changed. At the same moment, the 
sequence changes in the Project Window. The terminal block sequence can also be changed within 
the Project Window. These modifications are visible immediately in the terminal plan.  
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Up till now, these modifications have not yet taken effect in the circuit diagram. On the right-hand side 
of the line in the terminal plan, you can always see where the terminal is placed in the circuit diagram. 
Right-click on the text for terminal 21 to call up its context menu. Select the Jump to Schematic 
command, which automatically opens the corresponding sheet and marks the terminal in the circuit 
diagram.  
 

     
 
Arrange the sheets in the window so that you can see terminal 21 in the circuit diagram and in the 
terminal plan. Change the terminal number in the circuit diagram from 21 to 19 in the Text Properties. 
Notice how this change takes effect immediately in the terminal plan. Change terminal number 19 in 
the terminal plan to the value 21 in the Text Properties. This modification is also visible immediately. 
These modifications will also be updated immediately in the Project Window. 
 

  
 
 
These modifications not only apply to the terminal numbers but also when new terminals are added to 
a terminal block. These are also updated immediately in the terminal plan. Any modifications to the 
device designations or the wiring and cabling used are also immediately visible. 
 
Since the terminal plan with the activated online update option is always up-to-date, it is impossible for 
an outdated, “incorrect” version of the terminal plan to be displayed in your project. These 
modifications can be carried out wherever it is the easiest to do so. 
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Due to these modifications, we now may have an undesired sequence of terminal numbers being used 
on the terminal strip. Therefore, we have to renumber the complete terminal strip. For this 
E³.schematic offers the corresponding functionality.  
 
Select the Device Properties command from the context menu of terminal strip –XT2 in the Project 
Window and click on the Pin Names tab. A terminal strip can be completely or partially renumbered 
here according to different criteria. Enter the starting value as 10 in the line and close the menu with 
OK. You can now see that the terminal strip has been renumbered and the new terminal numbers are 
entered immediately in all views (project structure, circuit diagram, terminal plan). 
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Adding Graphic Text 

 
Circuit diagrams may contain free texts and graphics without electrical functionality. E³.schematic 
offers the user several possibilities for adding such elements to your drawings.  
 
We must now complete the drawing by adding the necessary text. Open sheet 9 containing the pump 

motors and use the Insert --> Text command or the  icon in the text format toolbar.  
 
Insert the text Drive of the pumps in the displayed Insert Text menu. The dialog allows you to type in 
the desired text (including multi-line text) and change the text parameters (e.g. font, text size, etc.). 
After clicking OK, the text will appear at the cursor position and can be placed anywhere on the sheet 
with a simple click of the mouse. In our example, place the text under the motor -M2. 
 
The text size can be changed at any time through the Text Properties using the corresponding icon 

 or simply by changing the marked text directly. 
 

   
 

Then add a rectangle around the previously created text. To do this, select the icon  in the graphic 
toolbar. The rectangle will be displayed at the cursor position and by clicking on one of the corner 
positions, drag a rectangle around the text.  
To change the line type, click on the line type scrollbar and select the broken line type. 
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Using Text Boxes 

It is possible to define a text box specifying the maximum width and height of a text. This text box is 
displayed as rectangle in which the text is displayed. A line break is done automatically. This box is 
defined by modifying (e.g. enlarging, minimizing, etc.) the text handles.  
 

 
 
 
We will now define such a text box. Open Sheet 16 in the 03-Circuit diagram folder. The text for the 
PLC output DO 000 is already defined as text box.  Modify the text box by enlarging it horizontally. 
The line breaks will disappear.  
 
 

 
 
 
To delete such a box (but keep the text), the corresponding option must be unchecked in the Text 
Properties. The option is only active if a box is already defined. 
Now right-click on the text and select the Text Properties command from the displayed context menu. 
By checking the Reset text box option, the text box can be removed. 
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Defining Fields 

To get a better overview of the plans, it is often useful to suppress common information, such as 
Device designation and Location, in an area. E³.schematic can use fields to accomplish this.  
 
On sheet 9, the connectors and the connected mating connectors have the same location designation. 
To suppress the display of the designations, use the Insert --> Field... command and while pressing 
the left mouse button, drag an appropriately sized rectangle around the connectors.  
 

 
 
Afterwards, right-click on the dashed line of the field and select the Field Properties… command from 
the displayed context menu. Device designation and Location designation can be specified for this 
field in the Field Properties dialog.  
 

 
 
Confirm the changes with OK. The values are suppressed for all symbols whose device designation 
and location designation correspond to those of the field. The suppressed values are not displayed. 
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Searching and Navigating within the Project  

Trying to find a specific element in a large drawing can be very time-consuming. E³.schematic, 
however, makes this task quite simple. You define the information to be searched for and.at the push 
of a button, the corresponding sheet will be opened and the element highlighted in the drawing.  

Select the Edit → Search command from the main menu bar or use the   icon or the function key 
F3. The Search dialog appears. Enter the search criteria in the menu.  
 
For example, enter the Object: Type as Signal and the 
Value of the signal to be searched as L1.  
This results in a search being carried out for all pins and 
connection lines, which have the signal L1.  
 
The search results will be displayed in the Output Window. 
By double-clicking on a line, you can jump directly to the 
sheet, on which the desired object is highlighted. This allows 
you to find information quickly, as well as keeping an 
overview of your drawing.  
 
 
 
 
 
 
 
 
 
 
 
 

 
 
To delete the highlighting found on this object, use the Edit → Reset Highlight command or press the 
keys SHIFT + F3.  
 

Switching between Display Modes 

In addition to the pure, graphical information found in the drawing, you can also find “logic background 
information” (often displayed in the form of attributes). E³.schematic makes it possible to display parts 
of this logic information. 

To switch between display modes, use the View → Connection Types command or the  icon.  
 
In the “normal” view, all connections are displayed as defined by their graphic attributes (color, line 
width, line type). Connection attributes are not shown graphically. This is the mode normally used to 
display the drawing’s printout. 
Once the Connection Types mode is activated, all connections will be displayed as defined, 
depending on their attributes in different colors and line types. Thus, it is possible to show connections 
for example with their signals assigned or wires placed. In addition to the signal, the signal cross-
references will be numbered. This gives you a quick,  
graphical overview of the connection information available in the project. 
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Displaying / Hiding Options 

Options in projects are objects that can be switched on and off and have an optional character 
assigned. By comparison, variants are attributes or objects that have various characteristics. 
The sample project contains two options: Additional pump 1 and Additional pump 2.  
Open sheet 12 of the 03-Circuit diagram folder.  
Check the “Draw elements with variants / options in other color” option in the Settings → Variants / 
Options → Display dialog.  

 

 
 
 
This option makes optional objects such as the devices –F4, -A2.2:8, -A2.2:29 and -P4, and their 
connections displayed in green.  
 
Now switch to the Project Window’s Variants/Options tab and deactivate the Additional pump 1 
option by unchecking the corresponding checkbox.  You will see that objects assigned the option 
Additional pump 1 are hidden.  
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The corresponding objects are also “hidden” in the Device tree view and also on Panel sheet 6.2 in the 
02-Panel folder.  
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Lists and Output Files 

Information contained in the project can be output to any document, list and/or file. 
 
Thus, E³ can be integrated in workflows in various ways. E³ offers for example predefined documents 
such as table of contents, bill of materials, connection lists, cable lists and terminal plans. 
 
It is also possible to work with E³ using the integrated programming interface (API). The API is based 
on Microsoft’s COM technology (COM Interface) and offers the possibility to load or add data to the 
drawing using any programming language.  
 
Several lists are predefined in E³ and can be output directly in Microsoft Excel, Access, Word or ASCII 
format. Lists that are output in external programs may require the corresponding license. However, 
these outputs can also be embedded in the drawing as separate sheets. 
 
To generate a cable list, use the Tools → Reports → Excel → Cables command. Excel starts 
automatically and generates a cable list, which contains all the cables used in the drawing along with 
any connected devices. 
 

 
 
 

To generate a complete parts list, start the Tools → Reports → Sheet → Bill of Material command. 
The sheets containing the Bill of Material will be added automatically to the drawing. 
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Table of Contents 

Select the Add-ons → E³.series Documents → Create Cover sheet command to automatically 
create a cover sheet with a table of contents. 
 
We are now going to add a graphic to our cover sheet, for example a picture of a pump or a logo. 
Select the command File → Import → Image… and then the Pump-Z22.jpg file from the directory 
C:\Users\Public\Documents\Zuken\E3.series_2020\data\Pumpe\ \. After placing the figure on the 
sheet, you can change its size. 
 
Lastly, we need to add a mechanical drawing to our cover sheet. This can be done quickly and quite 
easily with the DXF/DWG import command.  
Start the File → Import → DXF/DWG… command and select the SideView.dxf file from the directory 
C:\Users\Public\Documents\Zuken\E3.series_2020\data\Pumpe  
 
The DWG/DXF Options menu appears, in which you can specify the size and position of the 
mechanical drawing. To change the size of the drawing, click on the “handle” in the upper right-hand 
corner of the gray rectangle and move it back and forth to adjust the size. The drawing can also be 
moved by simply clicking on the gray rectangle and dragging it to the desired position on the sheet. 
Should an exact scale and/or placement be desired, these values can be entered directly in the menu.   
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The cover sheet should look something like this: 
 

 
 
 

Embedding Additional Documents 

Relevant information can be added to a project in E³.schematic if the user decides to do so. This can 
include documents from other applications, such as instruction manuals, buildup description, 
evaluation tables and so forth. E³.schematic allows you to integrate these documents into the project. 
A prerequisite is that the applications used to create these documents are compatible with Active-X 
(e.g., Microsoft Word, Excel). 
 
The following example will only work if you have Microsoft Word installed on your computer.  
Start the Insert → File… command. A menu appears, in which all of the Active-X compatible 
programs installed on your computer are listed. 
 
Note: Files embedded in the project with Insert -> Object… can be placed on a sheet and depending 
on the file, be edited within the project. Files embedded in the project with Insert -> File… are inserted 
in the project structure. If the option Create as reference is activated, the file is linked in the E³ 
project. If this option is inactive, a copy of the file is embedded in the structure. 
 
Select the file E³.schematic-e.doc from the folder 
C:\Users\Public\Documents\Zuken\E3.series_2020\data\Pumpe  
\ and confirm with OK. 
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The document is embedded in the drawing of E³.schematic. As 
soon as you click on the document in the Project Window, the user 
interface changes to the Word interface so that you can edit the 
document. As soon as a sheet is selected from E³.schematic, you 
automatically return to the E³.schematic user interface. 
 
Documents, which are embedded in your project, will also be 
saved. The file you selected, will remain in its original form and will 
not be changed by any actions within E³.schematic.  
 
 
 
 

Printing Sheets 

You can now print the sheets that you created or the entire project. 
 

To do so, select the File → Print… command or the  icon in the main menu toolbar. In the Print 
menu, you can specify for example which computer will be used to output the information, as well as 
the page format. 
 
 

Exporting as PDF 

The whole project can be exported as a PDF file. Thus, the project can be saved as a “neutral file” and 
can be displayed with any viewer that can read PDF files. To do so, select File -> Export -> PDF… 
from the main menu bar (a corresponding PDF license is required).  
 
Besides the graphic a project structure of the sheets will be exported. Cross-references are saved as 
“links” and can thus be jumped to directly.  
 
As in the Demo version the export functionality is not active, a PDF version of the project cannot be 
created. In the directories with the examples of the projects you will find, however, PDF files created 
from E³.series. 
 

Saving a Project  

 
After the entire project has been completed as well as the corresponding documentation created and 

printed, we must now save the project. Select the File → Save command or click on the  icon. You 
can also save the drawing under another name with the File → Save as… command in case you want 
to return to the original state of the drawing. 
 
You will need this completed project to continue working on the panel construction and wiring, which 
are described in the next chapter.  
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You should now be familiar with the basics of working with E³.schematic. Continue working with 
E³.schematic to become better acquainted with the wide range of functions the program offers, 
making the task of creating schematics much quicker and easier. 
 
 
 

 
Enjoy working with 
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First Steps 
 

Getting Acquainted with E³.panel for Panel Wiring and 

Construction 
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Welcome to Your First Tour through E³.panel 
 
In this chapter you will be able to familiarize yourself with the main functions of this program. You will 
see how to construct and wire the panel using the circuit diagram’s production data for manufacturing 
in combination with the circuit diagram. 
Please read through the respective forewords of the individual chapters and perform the described 
actions. Information, pertaining to basic operations and the user interface, can be found in the chapter 
The E³.series User Interface. At the end of this tour, you will have learned about the various functions 
of E³.panel, which can then be applied to your design needs. 
 
Have fun with this introduction! 
 

Opening an Existing Project 

E³.panel is an additional tool for E³.schematic or E³.cable. To work with it, a special license for the 
corresponding module is required. E³.panel is completely integrated into the circuit diagram’s creation 
and is based on the E³.series object-oriented data management system. This means that regardless 
of where the modifications are carried out, whether in the circuit diagram or in the panel wiring and 
construction, they will be updated immediately in all documents without the need for any additional 
updates. Thus, the panel construction offers another view of the components that have already been 
used and connected in the circuit diagram. Conversely, new components can be added to the panel at 
any time. They then exist as unplaced symbols in the circuit diagram, but as soon as the components 
are wired in the panel, the wiring information will also exist in the circuit diagram. 
 
The following example uses the circuit diagram that was created in the previous chapter. Before 
beginning this chapter, make sure you have completed the schematic according to the examples 
described before.  
 
If the program was ended and the drawing saved, start E³.series once again and open the project with 

the command  File → Open or the corresponding icon  from the toolbar. Select the project 
Cooling water pump from the directory 
C:\Users\Public\Documents\Zuken\E3.series_2020\data\Pumpe. 
 
Part of the panel and wiring of the cooling water pump already exist for this project. In the following 
chapter, we will complete the panel as well as output the corresponding production records. 
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Open sheet 6 in the folder 02-Panel. You can see the panel with its placed and wired devices. 
 
E³ can display the panel in 2D as well as in 3D view. This means, the panel layout can be shown two-
dimensionally as top view as well as three-dimensionally in a separate window. 
 
Naturally, all length specifications and checks in E³.panel are calculated and proofed so that real 
results can be output three-dimensionally. 
 
The areas in red show heat loss. Since this might not be very practical for drawing the plan, this level 
can be deactivated. Call up the Levels dialog using hotkey L or the View → Levels... command and 
deactivate the symbol graphic on level 200 (Power loss). 
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The panel view contains all objects relevant for the panel. 
In addition to the devices, we can see the mounting rails (yellow), on which the devices are “snapped”, 
as well as the cable ducts (white), in which the wires are routed. Mounting rails and cable ducts exist 
as devices in the project but have no influence on the circuit diagram. 
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Defining Mounting Rails and Cable Ducts 

Zoom in on the area to the left of the power switch –F9 and the motor circuit switches. We are now 
going to insert an additional mounting rail for a terminal strip and a cable duct here. 
 

To insert a cable duct, call up the Insert → Cable Duct... command or use the icon  from the 
toolbar. The duct’s width and height (some also say its depth) can now be defined in the menu. Enter 
the Width as 25 mm. It is also possible to specify an exact length for the cable duct. We will use a 
dynamic length for our duct. Do not enter a value for Length and close the menu with OK. Since a 
cable duct is treated as a device, it also receives a device designation.  
 
 
The cable duct symbol will appear at the cursor position. Position the cursor on the upper cable duct, 
press the left mouse button, drag the mouse onto the lower cable duct and release the mouse button. 
This establishes the duct’s starting point, length and direction, and then connects the two existing 
ducts.  
You can also “overlap” the existing cable ducts. E³.panel automatically adjusts the ducts to the right 
length. Notice the small circles appearing on the upper and lower cable ducts where the new duct 
touches them. This indicates that the channels are logically connected and that these ducts can now 
be wired. 
 
The mounting rail can be defined in the same way.  
 

Use the Insert → Mount command or the icon  from the toolbar. The Insert Mount dialog 
appears. Define the specifications for the mounting rail description. Enter the value TS 35 mm as the 
Slot Description. This is required because E³.panel uses this description to see if a device can be 
placed on a specific mounting rail. It compares the device’s mounting rail description to see if it 
matches the mounting rail type, on which it will be placed. If it does, then it can be placed on this 
mounting rail, otherwise it rejects the placement. This prevents devices from being placed on a 
mounting rail, on which they do not fit. Insert the new mounting rail vertically in this area. 
 
After the cable duct and mounting rail have been placed, they can be moved and their size changed at 
any time. Simply press the left mouse button and move them. 
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Placing Devices 

Devices, which already exist in the circuit diagram, can now be placed and wired in the panel. Every 
device in the circuit diagram, which contains a corresponding panel description in the database, is 
listed in the Not Placed tab of the Panel Tree view in the Project Window. 
This makes it easy to recognize, which devices can still be “placed“. 
Devices are placed in the panel just like symbols in the circuit diagram using “Drag & Drop”. Each 

device is represented by a symbol, the device model ( ). This can be dragged from the Project 
Window onto the panel sheet.  
 
Open the Panel - Not Placed tab and there under the folder +S1.MP you will find the device -F1. This 
needs to be placed on the appropriate mounting rail in the panel.  
Drag the device –F1 from the Project Window and position it on the mounting rail between the devices 
–F9 and –F2. As soon as a device is moved from the Project Window, all mounting rails, on which the 
device can be placed, are highlighted. When the device touches a highlighted mounting rail, it is 
snapped onto this rail.  
Devices cannot be placed on one another, on cable ducts or on other invalid surfaces. E³.panel 
checks this constantly and only allows devices to be placed at valid positions.  
 

 
 
As soon as a device is placed, it is moved from the Panel - Not Placed tab to the Panel – Placed tab. 
In this tab, you will find all devices, mounting rails and cable ducts structured according to their 
placement. This makes it easy to recognize, which devices are placed on which mounting rails. 
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When placing a complete terminal block, the individual terminals are not placed one after the other but 
rather, they will be selected as an area from the Project Window Panel – Not Placed tab and then 
placed through the context menu. Switch to the Project Window’s Panel – Not Placed tab, select the 
corresponding terminals of terminal strip -XT3. Call up the context menu and select the Place 
command to place all of the terminals at once.  
Note: If the terminals cannot be placed, the distance between the terminal strip and the mounting rail 
is too short. 
 

   
 
The terminal block will be completed with the appropriate end clamps 
(component: 249-117) and end separation plates (component: 280-
331) from the database. 
  
 
 
 
 
 
 
 
 
 
 
Not only can devices, which are already used in the circuit diagram, be placed, but components can 
also be taken directly from the component database and placed in the panel. Therefore, a component 
can be loaded directly into the project and then used later in the circuit diagram. Components are 
loaded from the Database Window onto the panel sheet using “Drag & Drop“.  
 
Open the folder Electric – Main contactor 3-pole AC in the Database Window Component tab. 
Search and select the component 3RT10151AB01. You can see the model, which the component has 
been assigned in the Preview Window, provided that the panel sheet is active.  
 
Place the component on the lower mounting rail directly next to the device –K1. By dragging the 
component onto the panel sheet, it is loaded into the project and simultaneously placed.  
To select the device in the Project Window, call up the command Jump to Tree in the context menu. 
You can also see, on which mounting rail the component was placed as well as the new device 
designation it was assigned in the Project Window.  
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If you switch over to the Device tab in the Project Window, you will see all of the device’s circuit 
diagram symbols there. They are not yet placed and can now be used in the circuit diagram. 
Modifications, which are made to the circuit diagram, will be updated immediately in the panel layout.  
You can, for example, change the device designation in the Device Tree from –Q1 to –Q100 using the 
Rename command in the context menu or the function key F2. As soon as the renaming has been 
completed, the new device designation will be entered automatically on the panel sheet. 
 

Wiring in the Panel 

All electrical connections, which are defined in the circuit diagram, will be converted into “real” wires in 
the panel wiring. If wires or cables are already defined in the circuit diagram, they will also be used. 
Otherwise, the defined wire type will be used as the standard wire, provided that it fits. 
 
In order to see, which connections are already 
defined in the circuit diagram, switch on the signal 
logic display. This can be easily accomplished by 

pressing the  icon from the toolbar.  
 
You can see broken lines directly connecting some 
of the connect points. These show the wires, which 
must be laid. The connections show the shortest 
pathway and the defined connection sequence, 
depending on the number of wires, which can be 
assigned to a pin. 
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To save time when routing wires, E³.panel offers the possibility to 
create connections automatically. 
Select the devices –F9 and -F1 on the panel sheet, right-click 
and select the Panel Autoconnect command from the context 

menu or  from the toolbar. E³.panel now starts the automatic 
routing, in which it tries to find the nearest cable duct and the 
shortest connection within the cable duct net. When routing, 
boundary conditions, such as fill size and provisions for restricted 
areas, are considered. 
 
        
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Now create the routing for the complete panel. 
You can use the Panel Autoconnect command for each individual device or for an area, which 
contains several devices, or by using Ctrl+A to select all devices on the sheet and then execute the 
command. 
 
To route only one wire to a pin, the command can also be started through the pin’s context menu. In 
this way, it is also possible to route all wires in the panel. 
 
If it is not possible to route a wire (no cable duct 
pathway found, all ducts are full, too many wires 
to a pin, the defined wire cross-section does not fit 
the connection), this will be displayed in the 
Output Window’s Results tab. You can then react 
in a corresponding manner (enlarge the cable 
ducts, define other pathways, change the wire 
type in the Tools → Settings → Connection → 
Conductors/Wires or using the toolbar).   
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Now we also want to see the results in the circuit diagram. 
With the automatic panel connection, each wire was assigned a logic connection. 
Click on the middle wire coming from the 
underside of device –F1. The wire will be 
highlighted and its routing can be easily 
viewed. Call up its Connection 
Properties from the context menu and 
click on the Wires tab. The wire will be 
displayed with its wire attributes, 
connected devices and wire number. This 
is automatically assigned as an ascending 
number, which can also be changed. 
Keep in mind the wire number (e.g. 403). 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
Close the panel sheet and switch to the Project Window’s Devices tab. Locate the wire 403 in the 
<Wires> folder and select the command Jump to Schematic in the wire’s context menu. This opens 
the corresponding sheet in the circuit diagram showing the connection on which this wire was placed 
by E³.panel and highlights the connection. 
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3D Panel Display 

The 3D panel functionality in E³.series builds upon the familiar 2D functionality. 
It is possible to dynamically switch between the 2D and 3D display on the base sheet. All commands, 
like Place, Move, Rotate, Route and so on are possible in both 2D and 3D views. 
. 

 
 
 
 
To toggle between the different display modi we will use the Panel toolbar. Right-click on any toolbar 
and select Panel from the displayed context menu. 
 

 

 Inserts a new mounting rail. 

 Inserts a new cable duct. 

 Inserts a new model contour (restricted areas, cutouts or drill-holes). 

 Automatically creates physical routing in panel. 

 Displays the wire parameters. 

 Displays the connection logic lines on pin. 

 Marks sheet comprehensive wires. 

  Switches between 2D and 3D view. 

  Displays models in wireframe or solid mode. 

 Displays perspective or orthographic (vertical) projection. 

  Activates/Deactivates lightning for various shading effects. 

  Displays model orientation in 2D. 
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  Displays model orientation in 3D. 

  Displays 2D model graphic (top view) in 3D. 

 Displays STEP models in 3D. 
 
 

Navigating within 3D View using Mouse 

 
For navigating within the 3D view, the mouse keys are used as follows: 
 

Mouse Assignments Function 

Click left mouse button Selects object 

Click and hold left mouse button Move mouse horizontally to rotate 3D world on Z 
axis; move mouse vertically to rotate 3D world on 
X and Y axes. 

Shift + click left mouse button Add or remove an object 

Ctrl + click left mouse button Jumps to the tree view 

Click right mouse button Calls up object menu 

Click and hold right mouse button Moves the 3D world on the X and Y axes. 

Scroll bar Zoom 
A zoom rectangle can be created (like in 2D). 

Click and hold right and left mouse buttons 
simultaneously 

Rotates complete 3D world 

 
Try the various 3D display and navigation possibilities. 
 
 
We will now enhance the right panel on the panel base sheet 02-Panel\6 in 3D display mode. 

Activate the 3D display mode   , the 2D model graphic display  and the orthographic (vertical) 

display  using the Panel toolbar. 
 
We will start by moving the left side wall and the floor onto the panel’s back wall. 
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Before placing the top on the panel back plane, we need to add a signal lamp to the outside of the top.  
 
To do so, right-click on the top and select the Move (Rotate) command from the displayed context 
menu, right-click again and select the Pivot forwards command from the displayed menu. Place the 
top. The top view corresponds to the top outside.  
 
The following hotkeys are available for the “pivot” commands:  
 
Pivot backwards:  Shift + arrow key up 
Pivot right:   Shift + arrow key right 
Pivot forwards:  Shift + arrow key down 
Pivot left:   Shift + arrow key left 
 

 
    
 
 
 
 
Now, select the indicating lamp 201.100.75 from the Electric-→ Indicating element/lamp folder and 
place it on the outside (upper side) of the top. Pivot the lamp forwards. The 3D view shows how the 
lamp goes through the top. 
 
 
Next, we will mount the right side wall and a main switch to the back plane.  
Select AE1180500-SW from the Electric → Cabinet folder of the database and place it to the right 
side of the panel. 
Then switch to the Database window again to select the main switch 3LD11040TB51 from the 
Electric → Main switch folder and place it on the inside of the side wall.  
Then pivot the side wall to place it onto the back plane. Right-click on the side wall, select the Move 
(Rotate) command from the context menu, then right-click again and select the Pivot left command. 
Afterwards, move the pivoted side wall to the right side of the panel back plane. 
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The completed panel should look as follows: 
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Dimensioning the Panel 

We will conclude by adding dimensions to our panel. In this example, we will use the panel door of the 
complete cabinet. Open sheet 6.3 in the 02-Panel folder. 
 

The dimensions can be defined by using either the Dimension  icon or the hotkey M 
 
 
or the Insert → Dimension command in the Main Menu. 
 
In the example shown, we will use the middle of the cable ducts. E³.series identifies potential 
dimension points by a cross. Click on a possible dimension point with the left mouse button. Find the 
second dimension point in the same way. Click on the left mouse button once again to define the 
dimension. 
  
 

 
 
 

Outputting a Wiring List  

E³.panel can generate a wiring list, in which all of the wires that have been placed will be output along 
with their attributes (From, To, Wire number, Wire type, Color, Wire cross-section, length and routing). 
Execute this function with the Add-ons → EXCEL Documents → Wiring List from Panel command 
from the main menu bar. 
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This was a short overview of the functionality of E³.panel. If you continue working with E³.panel you 
will get to know other functions, which will support your work and your preparation for production. 
 

 
 
 
 
 

Enjoy working with 
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Welcome to Your First Tour of E³.cable for Cabling Devices 
 
By following the steps described below, you will be able to familiarize yourself with the main functions 
of E³.cable for cabling devices. This tour points out how to create reliable circuit diagrams and cable 
drawings. Please read through the respective forewords of the individual chapters, which will then 
allow you to perform the described actions. Information, pertaining to basic operations and the user 
interface, can be found in the chapter The E³.series User Interface.  
At the end of the tour, you will have learned about the various functions of E³.cable, which can then be 
applied to your design needs. 
 
 
Have fun with this introduction! 
 
 

Opening an Existing Project 

With E³.cable, you always work within a project. A project may be comprised by any number of 
drawing sheets and additional documents, which are stored in a single file. Start the program. 
 

To open a project, use the File → Open command or the corresponding icon  in the standard 
toolbar. Select the project CD-Player.e3s from the directory 
C:\Users\Public\Documents\Zuken\E3.series_2020\data\CD-Player\. 
 
First, the project language needs to be defined. Select the Tools → Settings command from the main 
menu bar to open the Settings → General → Language dialog. Define British English as the first 
language. Confirm with OK. 
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Changing the Sheet Format 

Switch to the Project Window’s Sheet tab. Open the Circuit diagram folder and select sheet 2 by 
double-clicking on the sheet itself or by simply clicking on the box in front of the sheet.  
 
Different sheet formats (e.g. DIN, extra-wide, Ladder Diagram for the American market, etc.) with their 
unique size, layout and sheet header information are stored in the database.  
  
The sheet format used in this example is DINA1. 
The sheet format can be changed at any time 
through the Sheet Properties menu. Right-click 
anywhere on the sheet to reveal the Sheet 
Properties menu and by clicking on the Format 
field, a drop-down list of all the sheet formats 
defined in the database will appear. 
 
If a sheet format selected does not “fit” to the sheet 
and its information, an error message is displayed. If 
this is the case, make sure you select an 
appropriate sheet format. 
 
 
 
 
 
 

Entering Sheet Header Information 

Sheet headers contain information typically found in the drawing sheet’s margins, e.g. Drawing Title, 
Drawn by, Date, Revision, and so forth.  
The sheet headers are displayed in the Sheet Properties… menu, which can be called up through the 
context menu by right-clicking on any empty area of the sheet or on the sheet in the Sheet tree view. 
 
The standard text can now be entered in the sheet format. 
Enter the text Feed for the Name (1) attribute, and Main Current for Name (2). 
Confirm with OK. The texts are displayed in the sheet’s footer. 
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Placing Blocks 

The example drawing contains several functional blocks. A functional block or simply block, contains 
either an electronic circuit (i.e. originating from an EDA system) or, as in the example, represents a 
functional unit (like a black box). 
 
 

 
 
 
Now, place an empty block and label it. To place a block 
in the drawing, use the command Insert → Block… from 
the main menu bar. Select the standard block symbol 
STDBLOCK from the drop-down list in the Insert New 
Block dialog. The block symbol appears at the cursor 
position and can now be moved to the desired location. 
Left-click to place the block above the regulator board. 
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Next, select the connector MIMA-04-FO from the Electric - Micro-MaTch folder in the component 
database and place it on the block as shown in the image below.  
 
The connector’s contacts can be placed as a complete connector, as a pin group or as single pins. In 
our example, we will display them as single pins. Open the connector in the Database Window, select 
all of its pins simultaneously and place them onto the block’s border using Drag & Drop or the Place 
command in the context menu. The connector pins snap on the border and can be moved along the 
block. 
 

 
   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Placing and Connecting Device Elements  
 
The circuit must now be completed by adding a transformer. Select the component 59430 from the 
Generic_E - Transformer folder in the Database Window and place it as shown in the figure. 
 
Connect the transformer’s primary connections 7 and 8 to the block connector pins. This can be 

accomplished by using the Connection command in the pin’s context menu, the  icon or the key 
C. 
 
Once the command is activated, the cursor’s shape changes. Position the cursor on one of the block’s 
connector pins. Notice how its shape changes. Left-click on this pin to start drawing the connection. As 
you move the mouse, the connection is displayed as it would be drawn along with any corner points, 
which are automatically defined by the program.  
 
Corners can also be entered manually by clicking the left mouse button. When the mouse is moved 
across another possible connect point, the cursor again changes shape. Click on the mouse to 
complete the connection. 
 
Once connected, the appropriate connector pins will be added automatically to each end of the 
connection. Since possible mating connectors and crimp parts for the connectors are already defined 
in the database, E³.cable will use the mating connector defined for the connector pin. 
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Plugging (Unplugging) Plug Connectors 

We now have to connect the transformer’s secondary pins with the predefined plug connectors. Select 
one or several plug connectors simultaneously and by dragging, connect them to the appropriate 
pin(s). The elements are physically connected when the status bar turns yellow and the cursor 
displays two connected connectors. 
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Modifying the Cable Structure 

The six graphical connection lines have already been assigned conductors. Together they form the 
cable –PS_X1 that is displayed the Project Window Device tab. We must now add shields to the 
conductors as shown in the example. To do so, enclose the single conductors in pairs by shield 
symbols.  
In E³.cable, all conductors located under a shield symbol are considered to be shielded.   
 
Drag the shield symbol SHIELD3*2T from the Electric - Shield folder in the Misc tab of the Database 
Window and place it so that it overlaps the top two connect lines. Repeat the same procedure with the 
other two pairs of connections. 

 
 
 
Next, we have to place the shield symbol SHIELD5*3T over all six conductors. This symbol must be 
adjusted dynamically. To do so, select the shield symbol and adjust its height correspondingly. Drag 
the upper middle selection mark so that the shield overlaps all six connect lines. 
 
The shields have been dynamically added to the cable –PS_X1 in the Project Window Device tab and 
if any additional changes are made, they will be updated immediately. 
 
Select all six conductors belonging to cable –PS_X1 in the drawing sheet, right-click and select the 
Connection Properties command. All information, regarding the structure, signals, pins, line 
characteristics and attributes, will be displayed and can be modified as required. 
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Modifying Existing Drawings 

It must be possible to modify an existing drawing quickly, easily and reliably (checked). 
 
With E³., changes are displayed instantly in all representations of an object. Checks can also be 
executed for views that are appropriate to the workflow.  
Connected components can be moved quickly and intelligently, also to other sheets.  
 
When deleting a symbol from an existing connection, the connection closes automatically, provided 
that the attributes assigned to the connection, permit it. Otherwise, the connections remain 'open'. 
 
 

Adding Text 

In order to complete the sheet, we must add free texts, which do not belong to any component or 
symbol. 
 

This can be accomplished by using the command Insert → Text or the  icon in the text toolbar. The 
Insert Text menu appears. 
 
The Text menu allows you to type in the desired text (including multi-line text) and define the text’s 
parameters (e.g. font, text size, etc.). After clicking OK, the text will appear at the cursor position and 
can be placed anywhere on the sheet with a simple click of the mouse. 
 
Free texts can also be attached to an element. Select the desired element as well as the free text and 

“group” them together using the Group Graphic icon  found in the graphic toolbar. 
 
Text can also be accessed through the Text Database by pressing the F3 key in the input menu.  
 
Texts placed through the Translation Table will be translated online when changing the language and 
multiply displayed, if required. The project language can be defined in Tools → Settings → General 
→ Language. 
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Searching and Navigating within the Project 

 
Trying to find a specific element in a large drawing can be very time-consuming. E³.cable, however, 
makes this task quite simple. You define the information that will be used to search for the desired 
element in the Search menu. At the push of a button, the corresponding sheet will be opened and the 
element highlighted in the drawing.  

The Search menu can be called up with the Edit → Search command, the  icon or the function 
key F3.  
 
Enter the object type and value in the menu that you want searched.  
 
The search results will be displayed in the Output Window. By double-clicking on the desired line, you 
can jump directly to the sheet, on which the desired object is highlighted. This allows you to find 
information quickly, as well as keeping an overview of your drawing.  
 
To delete the highlighting found on this object, use the Edit → Reset Highlight command or press the 
keys SHIFT + F3. 

Defining Cables 

Connections are initially drawn as graphical connection lines but they can be completed with cable 
and/or conductor information. E³.cable makes it easy to assign individual conductors or any number of 
conductors to their corresponding graphical connection lines. No distinction is made between user-
defined cables and predefined cables selected from the database. 
 
Cables selected from the database, referred to as cable types, cannot be easily changed in the 
project. They retain their conductor arrangement, defined shielding and attributes, as long as the cable 
type is not modified. 
 
We must now insert a user-defined cable. Select the Insert → Cable command, check the Create 
custom cable option and add nine conductors.  
The individual conductors are numbered consecutively and displayed in the menu window. They can 
be renamed using F2 or rearranged here as required. Use the arrow buttons to arrange the 
conductors in the desired sequence. Rename conductor 9 to GND. 
 
Click OK and the newly created cable (-W1) is added to the Device Tree View in the Project Window. 
The conductors are displayed in yellow, which indicates they can still be used in the drawing. 
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Assigning Conductors 

The newly created cable (-W1) is to be assigned to an existing connection line and connected to the 
socket –X5CB. Locate the socket in the plan using the Search functionality. Zoom in on the area so 
that the socket and the connect line are clearly visible. 
 
We must now assign the predefined cable –W1 to the socket –X5CB on the connection line. Since a 
1:1 connection is desired here, drag the cable –W1 from the Project Window Device tab (the green 
symbol) onto the connection line. The connection line is highlighted as soon as it is recognized as 
such by E³.cable. After releasing the mouse button, the cable’s nine conductors are assigned to the 
connect line. 
 
 

 
 
 
Verify using the cable’s Connection Properties that the conductors have been assigned 1:1 to each 
of the socket pins. Since the connector pins already have defined signals, these signals merely 
continue through the conductors. 
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Placing Different Connector Views 

In order to meet the needs of the different documentation types, E³.cable supports the use of different 
connector views. Depending on the application, they can be depicted as overhead or side views, as 
single-pin or as complete connector representations. 
 
A view is nothing more than a new graphical representation of a connector. It has the same 
characteristics as the original view. If information in one of the views is changed, it will also be 
changed in all other views of the same connector. This means that no matter where the change is 
made, all representations will be updated instantly. A connector view is another view of the same 
element. The different connector views are defined in the database. 
 
We must now create an additional view for the socket –X5CB. This special connector view is a 
dynamic signal table. To create the signal table, right-click on the socket –X5CB in the Project Window 
Device Tree and select the command Place New Device View … in the context menu.  
 
Select Place as: single pins and the TABWIRE symbol name, which represents one line of the signal 
table. Click on Place and position the table next to the socket in the drawing on sheet 2. 
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The signal table now lists the signals, which are defined for the individual connector pins of –X5CB 
and the cross-references to their original pins. 
 
 

 
 
The signal definition can now be changed in the signal table as well as on the connector pins 
themselves. Both views of the socket are dynamically updated. This also applies when the views are 
placed on different sheets.  
Any modifications, regardless of where they are carried out, will be updated immediately in the project. 
 
Open sheet 3 and review the signal tables for the connectors in the project. 
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Switching between Display Modes 

In addition to the pure, graphical information found in drawings generated with E³, logic background 
information is also contained in the plan (often displayed in the form of attributes). E³.cable makes it 
possible to display this logic information. 

To switch between display modes, use the command View → Connection Types or the  icon.  
 

  
 
In the “normal” view, all connections are displayed as defined by their graphic attributes (color, line 
width, line type). Connection attributes are not shown graphically in the “normal” view. This is the 
mode normally used to display the drawing’s output. 
 
Once the Connection Types mode is activated, all connections will be displayed with different colors 
and line types, depending on their attributes (e.g., does the connection have a signal, and does it 
contain a wire). In addition to the signal, the signal cross-references will be numbered. This gives you 
a quick, graphical overview of the most important connection information available without having to 
continuously check the Connection Properties menu. 
 
 

Lists and Output Files 

Information contained in the project can be output to any document, list and/or file. 
 
That is how E³ can be integrated in various ways in the workflow.E³ offers for example predefined 
documents such as table of contents, bill of material, connection list, cable list and terminal plan.  
It is also possible to work with the integrated Visual Basic programming interface (API). This API is 
based on Microsoft’s COM technology (COM interface) and offers the possibility to load or add data to 
the drawing using any programming language.  
Several lists are predefined in E³ and can be output directly in Microsoft Excel, Access, Word or ASCII 
Format, provided that they are installed on your PC. For example, you can create the cable list as an 
Excel file integrated in the drawing. 
 
To do so, select the Tools → Reports → Excel → Cables command. Excel starts automatically and 
generates a cable list, which contains all of the cables as well as the devices they are connected to in 
the drawing. 
 
These reports can also be inserted at any time as separate sheets into the drawing. To generate a 
connection list, select the Tools → Reports → Sheet → Connections command. One or several 
sheets are created containing all connection details. The sheets are added to the Project Window’s 
Sheet tab. 
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Cover Sheet with Table of Contents 

Start the Add-ons → E³.series Documents → Create Cover sheet command. E³ automatically 
creates a cover sheet with a table of contents. 
 
Fill the sheet texts as desired. In the example the sheet text Customer is defined as Customer X and 
Order number is 1234567. To do so, click anywhere on the sheet and select the Sheet Properties 
command in the context menu. Enter the corresponding text in the appropriate fields. Press OK and 
the text is displayed on the sheet. 
 

 
 
 
 
Next, add a mechanical drawing to the cover sheet. This can be done very quickly with the DWG/DXF 
Import command.  
 
Start the File → Import → DXF/DWG command and select the cd-top.dwg file from the directory 
C:\Users\Public\Documents\Zuken\E3.series_2020\data\CD-Player\. A menu appears, in which you 
can specify the mechanical drawing’s size and position. 
 
Change the gray rectangle’s size by moving the “handle” in the upper right-hand corner back and 
forth, and then position it on the sheet accordingly. If an exact scale and placement position are 
desired, these values can be entered directly in the menu. Click OK. 
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We also want to add an image to our cover sheet, e.g. a company logo. Start the File → Import → 
Image command and select the file E3-Logo.tif from the directory …\data\.  
Place the E³.series logo on the sheet and then adjust its size. 
 

Embedding Additional Documents 

Relevant information can be added to a project in E³.cable if the user decides to do so. This may 
include documents from other applications, such as instruction manuals, design description, 
evaluation tables and so forth. E³.cable allows to integrate these documents into the project. A 
prerequisite is that the applications used to create these documents are compatible with Active-X 
(e.g., Microsoft Word, Excel). 
 
The following example will only work if you have Microsoft Word installed on your computer.  
 
Start the Insert → Object… command.  
 
Note: Files embedded in the project with Insert -> Object… can be placed on a sheet and -depending 
on the file- edited in the project. Files embedded through Insert -> File… are integrated in the project 
structure. When the Create as reference option is activated, the file is linked in the E³ project. When 
the option is inactive, a separate copy of the file is embedded in the structure. 
 
The Insert Object menu appears displaying all programs installed on your computer that are 
compatible with Active-X. 
The menu is always displayed in the language defined for the operating system. 
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To open an existing document, select the Create from File option and click on the Browse… button. 
Select the file C:\Users\Public\Documents\Zuken\E3.series_2020\data\CD-Player\\E3.cable-e.doc. 
 
Microsoft Word with the document selected is now started within E³.cable. The E³ user interface 
changes to the Word interface so that you can edit the document. As soon as a sheet is activated from 
E³.cable, you automatically return to the E³.cable user interface. 
 
 
The Word document, which is embedded in your project, will be saved as copy together with the 
project. The file selected will remain in its original form and will not be changed by any actions within 
E³.cable.  
 
 

 

Printing Sheets 

The sheets that have been created or the entire project can be printed. 

To do this, select the File → Print… command or the  icon in the toolbar.  
The Print menu opens. Specify the printer to be used to output the information, as well as the print 
properties such as page format. Define whether to print all of the pages or only specific pages. For 
example, enter 1;2 if sheets 1 and 2 are to be printed. 
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This was a short overview of the functionality of E³.cable. If you continue working with E³.cable you 
will get to know other functions, which will support your work. 
 
 
 
 
 
 

Enjoy working with 
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First Steps 
 

Getting Acquainted with E³.cable for  
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 105 

Welcome to Your First Tour of E³.cable 
 
By following the steps described below, you will be able to familiarize yourself with the main functions 
of E³.cable for cabling vehicles. This tour points out how to create reliable circuit diagrams and cable 
drawings. Please read through the respective forewords of the individual chapters, which will then 
allow you to perform the described actions. Information, pertaining to basic operations and the user 
interface, can be found in the chapter The E³.series User Interface. At the end of the tour, you will 
have learned about the various functions of E³.cable, which can then be applied to your design needs. 
 
 
Have fun with this introduction! 
 
 

Opening an Existing Project 

With E³.cable you always work within a project. A project may be comprised by any number of 
drawing sheets and additional documents, which are stored in a single file. Start the program. 
 

To open a project, use the command File → Open or the corresponding icon  in the standard 
toolbar. Select the project MX-30.e3s from the directory 
C:\Users\Public\Documents\Zuken\E3.series_2020\data\MX 30\. 
 
First, the project language needs to be defined. Select the Tools → Settings command from the main 
menu bar to open the Settings → General → Language dialog. Define “British English” as the first 
language.  
 

 

  



 
 
 

 106 

Opening Sheet 1 of the Project 

Open the Circuit diagram folder in the Sheet Project Window. Select sheet 1 by double-clicking on 
the sheet itself or by simply clicking on the box in front of the sheet.  
 
The different sheet formats (e.g. DIN, extra-wide, Ladder Diagram for the American market, etc.) with 
their unique size, layout and sheet header information are stored in the database.  
 
The sheet format used for sheet 1 is DINA2. The sheet format can be changed at any time through the 
Sheet Properties menu. Right-click anywhere on the sheet to reveal the Sheet Properties menu and 
by clicking on the Format field, a drop-down list of all the sheet formats defined in the database will 
appear. 
 
If a sheet format selected does not “fit” to the sheet and its information, an error message will be 
displayed. If this is the case, make sure you select an appropriate sheet format. 
 

 

Entering Sheet Header Information 

Sheet headers contain information typically found in the drawing sheet’s margins, e.g. Drawing Title, 
Drawn by, Date, Revision, and so forth. The sheet headers are displayed in the Sheet Properties… 
menu, which can be called up through the context menu by right-clicking on any empty area of the 
sheet. 
 
Enter the text Block diagram for the Name (2) attribute. 
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Drawing a Subcircuit 

The existing block diagram must now be enhanced by adding an unload circuit. This unload circuit will 
then be connected to the other components using the cable set –W14.  
 
Switch to the Database Window’s Component tab. 

Open the folder Electric - Key-operated switch and click on the  box of the key operated switch 
3SB32014AD11 to display all of the symbols that are listed under it.  Drag the first symbol onto the 
sheet and position it above the block titled Motor control for lift. 
 

  
 
 
After that, drag the second, available symbol of the device -S1 from the Project Window’s Device tab 
and place it as shown in the figure using the Place command from the context menu. Before placing, 
right-click and select the command Rotate from the displayed context menu or use the key R. 
 
 

 
 
 
The key-operated switch’s two symbols cross-reference each other and the cross-references are 
instantly updated in case of any modifications. If a device’s elements are spaced relatively far apart or 
they are placed on different sheets, you can “jump” directly to a cross-referenced element by right-
clicking on the referenced text and selecting the Jump command from the displayed context menu. 
 
 
Next, place the indicator light 3SB32046AA20 above the key-operated switch’s NC (normally closed) 
contact. It can be found in the Electric - Luminous alarm box folder in the Component Database 
Window.  
 
Right-click on the indicator light and select the Place command in the context menu. Drag the 
indicator light onto the sheet and press the right mouse button once again. Select the Rotate 
command in the context menu and then place it accordingly. Compare your results with the screen-
shot. 
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We must now connect the subcircuit to the existing cable set by means of a connector.  
Open the folder Electric - Mini Universal MATE-N-LOK in the Component Database Window and 
select the connector MINI-MNL-04-S. Place the pins as single pins. To do so, select the connector’s 4 
pins in the Database View, right-click and select the Place command in the context menu.  
Drag the connector pins onto the sheet and, prior to placing them in the drawing, mirror them using the 
Mirror by Y-axis command. The individual pins can now be moved using the context menu’s Move 
(Rotate) command or Drag & Drop as shown in the screen shot.  
 

 
 
To connect the subcircuit, right-click on one of the pins and select the Connection command or 
simply press the C key. When creating connections, E³.cable defines the corners automatically and 
connects the desired pins. 
Compare your results with those here: 
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Now connect the connector pins with the existing cable set -W14. Right-click on the uppermost pin 

and select the Connection command from the context menu, use key C or the  icon.  
Scroll to the cable set and search the connection point. When the connection can be created, the 
cursor’s shape changes. Complete the connection by left-clicking on the pin. 
 
Since all potential mating connectors and connector pin terminals are already defined in the database, 
E³.cable always selects the appropriate mating connector for each connector.  
 
The three remaining connector pins can be connected to the cable set automatically. To do so, use 
the Insert --> Autoconnect --> Inside Area Horizontal command. After selecting the command, drag 
a rectangle around the three connector pins and the vertical connection line to -W14 that was just 
created. The connections will be inserted automatically after releasing the left mouse button. This 
command also works in examples containing more device elements than in this example.  
 

 
 
 

If a symbol is deleted from a connection, the connection will close automatically, provided that the 
attributes, which are assigned to both connections, permit it. Otherwise, the connections remain 
“open”. Likewise, if you want to add a symbol to an existing connection, E³.cable will undo the connect 
line and insert the symbol into the connection.  
 
E³.cable also dynamically supports the movement of elements and maintains the connections while 
moving. 
 
 

Plugging (Unplugging) Plug Connectors 

E³.cable also supports the plugging and unplugging of connector elements.  
To unplug a connector element, simply select it and drag it to a new position. After releasing the 
mouse button, the connection is broken. A connector element can also be plugged in by moving it in 
the direction of its mating connector.  
When the display window at the bottom of the screen turns yellow as well as a plug and socket symbol 
appear next to the cursor, this indicates that a connection was made. 
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Modifying the Cable’s Structure 

The example project already contains the cable set -W14 that needs to be enhanced by additional 
conductors. Right-click on the cable set –W14 in the Device View of the Project Window and select the 
Insert Conductors command from the context menu.  
 
Add four additional conductors to connect the unload circuit correctly. These conductors are 
automatically numbered 21–24. 

          
 
 
Confirm with OK. 
These conductors are added to the cable set and can now be assigned. Conductors, which have not 
been placed yet, are displayed in yellow in the Device View. 
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Assigning Conductors 

These new conductors can now be assigned to the connections between the unload circuit’s individual 
pins and the main connector –X1 on the block labeled Main distribution.  
Drag the individual conductors from the Device View onto an individual pin of the respective unload 
circuit’s socket connector (-X10). Release the left mouse button and position the cursor on the main 
connector –X1, which results in the pathway being highlighted as soon as E³.cable identifies the 
connector. By clicking on the pin -X1, the conductor will be assigned to this connection. Repeat this 
process for the other three pins. 
 

 
 
Now check to see whether you assigned the conductors correctly. Right-click on the connection line 
and select the Connection Properties command in the context menu. You can see the cable’s 
structure in the Cables/Conductors tab and which pins the conductors are connected to in the tab 
Wire/Conductor Connections.  
 

Defining Attributes 

The socket’s affiliation to the unload circuit must now be defined. Assign the socket –X10 the attribute 
Function. Right-click on the socket –X10 and select the Device Properties command from the 
context menu displayed. 
 
You can select the desired attribute from the left-hand side of the attribute table and enter its value in 
the right-hand side. The check box, which is located in front of the attribute name, controls whether the 
attribute is displayed or not. Enter the value Unload circuit for the socket –X10. 
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Adding Text 

In order to complete the sheet, we must add free text, which does not belong to any component or 
symbol. 

This can be accomplished by using the Insert → Text command or the  icon in the text toolbar. 
 
The Text menu allows you to type in the desired text (including multi-line text) and change the text’s 
parameters (e.g. font, text size, etc.). After clicking OK, the text will appear at the cursor position and 
can be placed anywhere on the sheet with a simple click of the mouse. 
 
Free texts can also be attached to an element. Select an object as well as the free text and “group” 

them together using the Group Graphic icon  found in the graphic toolbar. 
 
Texts placed through the Translation Table will be translated online when changing the language and 
multiply displayed, if required. The project language can be defined in Tools → Settings → General 
→ Language. 
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Placing Different Connector Views 

To meet the requirements of the different documentation types for electrical engineering, E³.cable 
supports the use of different views that can be selected for connectors. Different representations of the 
same cable set may often be required for assembly, service, manufacturing and customer 
documentation.  
 
Open sheet 2 in our sample project. The cable set –W14 for assembly and service is pictured at right. 
The elements displayed are nothing more than different views of the same connector elements shown 
in the block diagram on sheet 1. 
 

 
 
The newly created unload circuit is still missing a socket. To add this view, right-click on  
–X10 in the Project Window Device View and select the command Place New Device View… in the 
context menu. 
 
Select single pins, and the symbol W_BU from 
the Defined View Symbols list. Click Place. 
Next, mirror the pins on their Y-axis and place 
them above the connector view –X8#1 on the 
sheet. Position the cursor on the sheet. By right-
clicking, a context menu will appear which 
contains the Mirror by Y-axis command. 
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E³.cable is now able to display the logical conductor connections to connector view -X1#1. If this is not 
the case, they can be displayed by clicking on the Display unconnected conductors checkbox using 

the Tools → Settings → Connection → Cable/Conductor Logic Lines command or use the  
icon in the toolbar. 
 

 
 
 
Now connect the connector pins to the cable set. To automatically insert the connect lines and their 
conductor information, use the Connect or Insert → Autoconnect → Inside Area Horizontal 
command. After selecting this command, drag a rectangle around the cable set’s connect line and the 
newly placed connector pins. Upon releasing the mouse button, the connections will be inserted.  
 

 
 
 
Next, display the attribute Unload circuit on the 
connector. To do so, use the Device 
Properties… command from the context menu 
of connector –X10, check the box in front of the 
Function attribute and move the text to the 
desired position. 
 
 
Your results should look something like this: 
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Another view of the same cable set –W14 is displayed on sheet 3. Once again, the unload circuit’s  
–X10 socket is missing from the drawing. We are also going to add another view of the socket on 
sheet 3. 
 
Right-click on the connector -X10 in the Device Tree View and select the Place New Device View 
command. Select View number 2 and the symbol MINIMNL-S004SV. Since we want to place the 
view as a complete connector, activate this button also. 
 

 
 

 
Place the connector view on the left side of the sheet as shown in the example below. Connect the 
connector view with rest of the cable assembly. 
 
Your results should look something like this: 
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Switching between Display Modes 

In addition to pure, graphical information found in drawings generated with E³, logic background 
information is also contained in the plan (often displayed in the form of attributes). E³.cable makes it 
possible to display this logic information. 

To switch between display modes, use the View → Connection Types command or the  icon.  
 

       
 
In the “normal” view, all connections are displayed as defined by their graphic attributes (color, line 
width, line type). Connection attributes are not shown graphically in the “normal” view. This is the 
mode normally used to display the drawing’s output. 
 
Once the Connection Types mode is activated, all connections will be displayed as defined, depending 
on their attributes (e.g., does the connection have a signal, does it contain a wire). In addition to the 
signal, the signal cross-references will be numbered. This gives you a quick, graphical overview of the 
most important connection information available. 
 

Searching and Navigating within the Project 

Trying to find a specific element in a large drawing can be very time-consuming. E³.cable, however, 
makes this task quite simple. You define the information that will be used to search for the desired 
element in the Search menu. At the push of a button, the corresponding sheet will be opened and the 
element highlighted in the drawing.  

The Search menu can be called up with the Edit → Search command, the  icon or the function 
key F3.  
 
Enter the object type and value in the menu that you want searched. The search results will be 
displayed in the Output Window. By double-clicking on the desired line, you can jump directly to the 
sheet, on which the desired object is highlighted. This allows you to find information quickly, as well as 
having an overview of your drawing.  
 
To delete the highlighting found on this object, use the Edit → Reset Highlight command or press 
SHIFT + F3. 
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Lists and Output Files 

Information contained in the project can be output to any document, list and/or file. 
 
That is how E³ can be integrated in various ways in the workflow. 
E³ offers for example predefined documents such as table of contents, bill of material, connection list, 
cable list and terminal plan. It is also possible to work with the integrated Visual Basic programming 
interface (API). This API is based on Microsoft’s COM technology (COM interface) and offers the 
possibility to load or add data to the drawing using any programming language.  
 
Several lists are predefined in E³ and can be output directly in Excel, Access, Word or ASCII Format, 
provided that they are installed on your PC. For example, you can create the cable list as an Excel file. 
 
To generate a cable list, use the Tools → Reports → Excel → Cables command. 
The cable list will be generated in Excel and displayed on the screen. 
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Cover Sheet with Table of Contents 

Start the Add-ons → E³.series Documents → Create Cover sheet command to automatically create 
a cover sheet with a table of contents. 
 
Fill in the required sheet texts in the Sheet Properties. In the example, define the text Order (1) with 
the value 1234567. Confirm with OK. 
 
 

 
 
Next, we are going to add an image to our cover sheet, e.g. a company logo.  
Select the File → Import → Image command and then the E3-Logo.tif file from the directory 
C:\Users\Public\Documents\Zuken\E3.series_2020\data\. Place the E³.series logo anywhere on the 
sheet and then adjust its size. 
 
Lastly, add a mechanical drawing to the cover sheet. This can be done very quickly with the 
DXF/DWG Import command.  
 
Use the File → Import → DXF/DWG... command and select the mx30.dxf file in the directory 
C:\Users\Public\Documents\Zuken\E3.series_2020\data\MX 30\. 
 
A menu appears, in which you can specify 
the mechanical drawing’s size and 
position.  
 
Change the gray rectangle’s size by 
moving the “handle” in the upper right-
hand corner back and forth, and then 
position it on the sheet accordingly. If an 
exact scale and placement position are 
desired, these values can be entered 
directly in the menu. Click OK. 
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Your cover sheet should look like this: 
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Embedding Additional Documents 

Relevant information can be added to a project in E³.cable if the user decides to do so. This can 
include documents from other applications, such as instruction manuals, design description, 
evaluation tables and so forth. E³.cable allows to integrate these documents into the project. A 
prerequisite is that the applications used to create these documents are compatible with Active-X 
(e.g., Microsoft Word, Excel). 
 
The following example will only work if you have Microsoft Word installed on your computer.  
 
Start the Insert → Object… command.  
 
Note: Files embedded in the project with Insert -> Object… can be placed on a sheet and -depending 
on the file- edited in the project. Files embedded with Insert -> File… are integrated in the project 
structure. When the Create as reference option is activated, the file is linked in the E³ project. When 
the option is inactive, a separate copy of the file is embedded in the structure. 
 
The Insert Object menu appears displaying all programs installed on your computer that are 
compatible with Active-X.  
The menu is always displayed in the language defined for the operating system. 
 
To open an existing document, select the Create from File option and click on the Browse… button. 
Select the file  C:\Users\Public\Documents\Zuken\E3.series_2020\data\MX 30\E3.cable-e.doc.  
 

 
 
Microsoft Word with the document selected is now started within E³.cable. The E³ user interface 
changes to the Word interface so that you can edit the document. As soon as a sheet is activated from 
E³.cable, you automatically return to the E³.cable user interface. 
 
The Word document, which is embedded in your project, will also be saved as copy together with the 
project. The file selected will remain in its original form and will not be changed by any actions within 
E³.cable.  
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Printing Sheets 

You can now print individual sheets or the entire project. 

To do so, select the File → Print… command or the  icon in the main menu toolbar. In the Print 
menu, you can specify which computer will be used to output the information, as well as the page 
format.  
 
Select the Properties button in the Print menu. You can choose whether to print all of the pages or 
only specific pages. Enter the page numbers 1-3 to print the sheets you just modified. 
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You now know how fast and easy it is to work in E³.cable. However, this was only a short overview of 
the functionality. If you continue working with E³.cable, you'll quickly get to know other useful functions 
that make work much easier. 
 
 
 
 

Enjoy working with 
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First Steps 
 

Creating Symbols and Components with the 

E³.series Database Editor 
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Welcome to Your First Tour of How to 
Create Symbols and Components with E³.series 

 
 
Up till now, you have worked with components and symbols that already exist in the database. 
 
The following chapter will show how to create own symbols and components with E³.series and then 
save them to the database. 
 

What is a symbol? 

A symbol is a circuit element that can be assigned to a component. Since many components use the 
same symbols, these symbols only have to be described once in the database. They can then be used 
in any combination to create different components. 
 

What is a component? 

Simply put, a component is a predefined set of symbols with pins, which possess pin numbers. A 
component is loaded with all of its symbols. All of its symbols automatically have the same item 
designation. Components can also be assigned additional information, e.g. part numbers, description, 
supplier, price and so forth. 
 

Preparations for Creating Symbols 

 
Symbols and components are created and modified in Database Editor Mode. This is a special mode 
within E³.series that allows you to create components and symbols as well as enter standard 
definitions for the attributes, text, colors etc. in the databases.  
 
Since several users can access the databases simultaneously (configuration, components and 
symbols), all modifications are updated instantly for all users. If Database Editor Mode is started, a 
new instance of E³.series is started with specific database editor functions. To change to Project 
Editor Mode, for example, to use symbols from an existing drawing for a new symbol or to test created 
symbols or components, simply switch to the E³.series instance, in which a project is opened. 
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Creating a New Symbol 

The fastest way to create a new symbol is to use a similarly existing symbol as a template, make the 
required changes and save it under a new name. 
The following section, however, describes how to create an entirely new symbol without using a 
template. 
 
A new symbol is created in a few steps: 
 

• Define the symbol type and name. 

• Create the symbol’s graphics. 

• Define the pins. 

• Define the text types used and their position on the symbol (Higher level assignment, Location, 
Device designation, Pin name, …). 

• Define the origin. 

• Define the space requirement. 
 
 
We are going to create a new symbol for a valve coil. 
  
Switch to Database Editor mode to create the symbol. To do so, select the Tools -> Start Database 
Editor command from the main menu bar or right-click on the uppermost level in the Database 
Window and select the New Symbol command from the context menu. This will start a new instance 
of E³ in Database Editor mode. A drawing area for the new symbol is opened in Database Editor. 
 
 

 
 
 
 
 
 
The new symbol should look like this when finished: 
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The cross in the middle of the drawing area represents the symbol’s origin. It will also be used as the 
symbol’s first pin. 

Activate the display grid using the  icon. The grid points will help you in drawing the symbol. 
More grid settings can be defined in the Settings (Tools → Settings → Database Editor → 
Symbol). 
 
 

 
 
 
First, draw the graphic of the symbol. 
 
Zoom into the area around the origin and begin by drawing the rectangle and other lines as shown in 
the screenshot below. Use the Graphic toolbar to define and change the line width, color and type of a 
selected element. 
 

 
 
Remember to use the grid points to assist you when drawing the symbol. Activate the Copilot in 
Tools → Settings → Database Editor → Display to see the graphic’s size definitions while drawing.  
 
Using the Graphic Properties – Graphic Information tab it is possible to exactly define the graphic 
size. 
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Next, we have to define the pins. E³.series defines electrical pins including their preferred direction of 
approach.  
 
The upper pin is connected from top. Select the node symbol Node - from top 

 from the drop-down list of the Database Symbol Node toolbar 
and place it using the  icon.  
 
Define the second pin in the same way but use the node symbol Node - from bottom 

. 
 

 
 
The symbol is assigned the pin names of the component within which it is used. Therefore, the pin 
sequence within a symbol is very important when assigning them. 
 
Lastly, assign the symbol text nodes for the higher level assignment, location and device designation.  
 
Use the already defined template TEXT_L for the text positions. It can be found in the Misc view of 
the Database Window in the folder Electric - Misc_Template. The template TEXT_L can be placed 
like a symbol with Drag & Drop or by using the command Place in the context menu.  
 
Notice how the text nodes are represented by a green X in the drawing. This means that the actual 
values with their defined text parameters have been entered at this position. 
The graphic description is now complete. 
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To see what text will be entered at the text nodes, change the display mode with the  icon. 
 

 
 
 
 
The next steps are to define the symbol’s origin as well as its space requirement. 
 

To define the origin click on the corresponding icon  on the toolbar. Place the origin on the upper 
pin by left-clicking on the pin. 
 
Next, we will define the symbol’s 

space requirement. Click on the  
button on the toolbar. The system 
will define the space requirement 
based on the symbol’s graphics. To 
change the space requirement 
manually, adjust the rectangle 
around the symbol by dragging the 
corresponding handles. 
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Finally, we have to define several symbol-
specific properties such as the symbol’s name 
under which it is stored in the database.  
This information can be entered in the Symbol 
Properties dialog displayed when right-clicking 
on the drawing area and selecting the 
corresponding command from the displayed 
context menu: the name of the new symbol is 
G01Y001B, the symbol’s class is Coil (this 
defines the folder, in which the symbol 
appears), the schematic type is Electric.  
 
 
 
 
The symbol names used in the E³ database are 
in accordance with the definitions in the IEC 617 
standard. 
 
 
 
 
 
 
 
 
 
 
The symbol can be saved to the database using the Save to Database command in the symbol’s 
context menu or by using File → Save to Database in the standard toolbar.  
 
To exit Database Editor mode, use the command File → Close.   
 
The new symbol can be used in the circuit diagram by all users accessing this database. It might be 
necessary to refresh the database by clicking on the database name and pressing the F5 key. 
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Creating a New Component 

The following section describes how to create a new component. The new component is named 
GHR15511201R003. It is a loop contactor from the supplier ABB that has two NO contacts. To create 
this new component call up a similar one from the database, change it and save it to the database 
under a new name. 
 
In this example, use the component 3RT10151AB01 found in the Electric – Main contactor  
3-pole AC folder. Select the command New Component… from the component’s context menu. The 
Component Wizard is started and the new component can be created. 
Note: When this command is selected in Project mode, Database Editor mode is started. 
 

 
 
The Component Wizard guides you through the process of creating a component.  
 
First, define the new component’s type, name and other global parameters in the Identification 
dialog. In this example, we are going to create a standard device. Select Standard device and enter 
the name GHR15511201R003. 

 
  

 
Click Next. 
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The next step is to enter the component-specific attributes in the Properties dialog. These values 
define the new component. The values of the component on which the new component is based, are 
already entered under the Entry column. Change only those entries that have differing text. 
 

  
 
Note: Customer-specific properties can also be entered here. These must be previously defined in the 
Format → Attribute Names table. 
 
Click Next. 
 
Now define the component’s structure as well as the symbols that will represent the component in the 
circuit diagram. This is done in the Component Wizard - Structure dialog. 
 
If an existing structure is to be used, the component can be saved directly to the database without any 
additional steps. 
Note: If the structure is to be changed, it is recommended to create a copy of the structure. Changes 
done in this menu to any of the original component’s structure will apply to all components using this 
structure. This may cause undesired results in large projects.  
If a new copy of the structure is created, it can be edited at any time without the modifications 
affecting other components.  
 
Activate the Make new copy option in the menu. 
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Click Next.  
 
Finally, the Component Wizard allows you to decide whether to save the new component directly to 
the database or to continue editing the component.  
 
Activate the Edit component graphically option and exit the Wizard by pressing Finish. 
The component and its symbols are loaded to Database Editor for modification. 
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Setting Levels 

E³.series distributes information on various levels (or layers). Imagine these levels as transparent 
sheets, which can be displayed or not in the drawing. That is how it is possible to make the different 
information visible or invisible. Entire information types (e.g. empty text nodes) can also be switched 
on or off.  
When editing a component, it is not necessary to use all of the available information so just switch off 
the superfluous information using the levels command. 
 
To do so, select the View → Levels...  command or simply press the L key. A menu appears, in which 
you can switch on or off individual or all levels. The Read Configuration command is used for loading 
predefined level display configurations, the Write Configuration command is used to save existing 
configurations. 

 
 
Select the Read Configuration command and component-editor.vis file from the 
C:\Users\Public\Documents\Zuken\E3.series_2020\data directory and close the menu. The 
configuration is loaded immediately. Close the menu with OK. The display of the symbols that belong 
to the component is reduced now and much clearer. 
 
 
All of the component’s symbols along with their pin names as well as the component’s model (the 
component’s representation in the panel) will now be displayed in the drawing area. Additional 
symbols can be added here by placing them from the Database Window or existing symbols can be 
deleted. 
 

Show the symbol numbering by clicking on the “connection types” icon .The drawing area will look 
as follows: 
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In the following example, delete the component’s contact arrangement (marked as number 1), the 
symbol for the main contacts (marked as number 3) and the symbol for the display in another view 
(marked as view number 1). Replace them with another contact arrangement and an additional NO 
contact. The model in the example is irrelevant and can be deleted.  
 
First, delete the symbols 1 and 3 that are no longer required from the drawing area. To do so, click on 
the symbols and press the Del key or select the Delete command from the context menu displayed by 
right-clicking on the symbols. 
Note: The symbol numbering is dynamically changed when a symbol is added or deleted. 
 
Activate the view symbol displayed in the Database Editor window by the name ZUK07-02-01 by 
double-clicking on it. The view symbol is highlighted in the drawing area. Delete the view symbol as 
well as the model.  
Double.click on the component name to reset the display on the drawing sheet. 
 

 
 
Switch to the Symbol tab of the Database window and place the symbol ZUK07-50-36 from the 
Electric - Contact Arrangement folder. Drag it to the drawing area and arrange it above symbol 1. 
 
The second NO contact is stored in the symbol database in 
the Electric - Contacts folder. The symbol’s name is 
S00227. Place the contact symbol between the symbols 1 
and 2. 
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Pin names can also be defined and changed in the Database Editor. 
Selecting the Pin Assignment… command from a symbol’s context menu opens the Pin 
Assignment dialog in which the symbol’s pin names are displayed. Pin names can be entered here. 
Activate this command on the NO contact symbol S00227 that was added and enter both new pin 
names 24 and 23. Confirm with OK. 
 

  
 
The next step in defining the component is to determine the order of the symbols within the 
component. This mode can be activated with the Edit → Order Definition → Symbols in 

Component command or the  icon. The Symbol Order Definition dialog appears. 
 
Click on the symbols in the order in which they are to appear in the component. This 
means that the contact arrangement should be first, followed by the coil, then the 
contact with pin numbers 13, 14 and finally, the contact with the pin numbers 23, 24. 
 
The new sequence will be displayed on the symbols in the blue text boxes. Exit the 
symbol order mode by pressing the <ESC> key. 
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The last step in defining the component is to specify the relationship between the symbols within the 
component (in case component cross-references are desired).  
 
To do so, right-click on the contact arrangement ZUK07-50-36 and select the Master/Slave 
Assignment… command from the context menu. The Assign Slaves dialog appears. Transfer all 
symbols into the Assigned Slaves column. This produces an online cross-reference between the 
component symbols and the contact arrangement in project. 
 

  
 
With this, the complete component is defined and can now be saved to the database. Right-click on 
the drawing area and select the Save to Database command from the displayed context menu or the 
File -> Save to database command from the main menu bar. 
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Special Components 

In addition to standard symbols and components, E³.series can be used to create special 
components, especially for those used in E³.cable such as connectors and cables. 
 
A connector can be depicted in different ways in a project, not only as a connector pin or a socket. 
They can be represented as: 
 

• block connectors  

• documentation graphics, which are displayed in the Preview Window and placed using the 
Place as Graphic command 

• different views of a connector that can be selected by means of the Place New Device View 
command 

 
A component can also be a cable, referred to as cable types. A cable type describes a special cable 
that is used in a defined form in the project. Its structure cannot be easily changed. 
 
A cable type may contain the following information: 
 

• component master data 

• number of conductors with conductor attributes 

• cable attributes 

• shields 

• twisted pairs 

• bundles 
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Creating a New Connector 

Start the Component Wizard by selecting the New Component command as described above. The 
Database Editor mode is activated and the Component Wizard started, displaying the Identification 
page. 
 
Select the component type Connector. Enter the new component’s name as Connector1 and its 
device letter code (here X). 
 
Since a completely new connector component is created, nothing is entered in the lower section of the 
dialog where a component can be defined whose structure is to be used. 
 

 
Click Next. 
 
 
The Component Wizard’s Properties dialog is used to define the new component’s master data. If the 
new component is based on an existing component, these fields will already contain entries. Since a 
completely new component is created in the example, these empty fields must be filled. Select any 
properties for the new connector. 
 

  
 
 
For component attributes that are not displayed in the list, they can be added in the last line by simply 
clicking on the line and selecting the desired attribute from the drop-down list. These user-specific 
attributes, however, must be previously defined in the attributes table. 
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This can be accomplished by using the Format → Attribute Names command in the Database Editor 
mode. 
 
After defining the component's master data, click Next. 
 
The Component Wizard’s Connector Structure dialog appears next. The Completely new structure 
field is already active since a new structure for the connector is created. 
 
Select a connector symbol to represent the connector in the circuit diagram. Select the socket symbol 
W_ST.  
The connector display on a block is defined by the Block symbol. This definition is optional. In this 
example, however, a block symbol is also specified. 
Select the block connector symbol BL_ST. The new connector Connector1 can thus be placed on a 
sheet within the circuit diagram, as well as on a block. If the block symbol is not defined, the connector 
can only be placed in a circuit diagram 
Define the Number of pins as 4. 
 
 

 
 
Click Next. 
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The next step is to define the different Connector Views in the Component Wizard’s Connector 
Views dialog. A connector can be defined with any number of views. This definition is optional. 
 
The drop-down list displays all connector views that are available as symbols in the database.  
Select the symbol MINIMNL-P004TP as the side view and the symbol TABWIRE3 as a second 
possible view. The TABWIRE3 symbol is used to automatically create a table listing the pin 
designations, signals and conductor information. This symbol is useful for the cable documentation. 
 
 
Note: To delete a symbol, right-click on the gray field next to the symbol name and select Delete 
Symbol Name from the displayed context menu. 
 

 
 
If no alternative connector views are defined, the Component Wizard can be terminated by clicking on 
Finish. However, to complete the example, click Next. 
 
 

  
 
 
  



 
 
 

 141 

The Component Wizard Connector Master allows you to define the connector’s documentation 
graphics. This symbol already exists in the database. Select the MINIMNL-P004D symbol from the 
drop-down list. 
 
When selecting a component from the database, the master symbol will be displayed in the Preview 
Window. Master symbols can also be placed by means of the Place as Graphic command, and for 
documentation purposes, be attached to objects in the circuit diagram. 
 

 
 
To continue, click Next.  
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Finally, the Component Wizard allows you to save the newly created connector directly to the 
database in the Complete dialog. 
 
Select the option Edit component graphically. The new connector will be graphically displayed and 
can then be modified.  
 

  
 
 
Click Finish to exit the Component Wizard. 
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E³.cable opens a new sheet, in which the objects defined so far are arranged. 
 
 
 

 
 
 
 
 
 

 Display of connector pins on a block 
 

 Display of the connector pins outside of blocks 
 

 Other view(s) of the connector 
 

 Display of the connector in the Preview Window and when placed as graphic 
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The Component Properties dialog box allows to define active Mating Connectors and Connector 
Pin Terminals. 
 
In the example, the definitions for mating connector and connector pin terminal are valid for the whole 
connector and all pins. However, it is also possible to define valid connector pin terminals for each 
specific pin. The mating connector is automatically loaded from the database and placed upon 
connecting to the connector. 
 
Right-click on the drawing sheet and select the 
Component Properties… command from the displayed 
context menu. Switch to the Pins tab and add the 
corresponding attributes Valid mating connector and 
Valid cavity part, then select values from the drop-down 
list. The valid cavity part is assigned the value MINI-B-0.5-
1.5 and the valid mating connector is assigned the value 
MINI-MNL-04-B. Select the cavity part as Active 
connector pin terminal. 
 

      
 
 
 
 
 
 
 
 
 
 
 
 
 
Lastly, the pin names can be changed. Right-click on the 
drawing sheet and select the Pin Assignment… command from 
the displayed context menu. 
If the pins are not defined, they will be numbered sequentially. In 
the example, the pin names will be changed (a, b, c, d). 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
The new connector component, which has been completely described, can now be saved to the 
database. To do so, right-click in the drawing area and select the Save to database command from 
the displayed context menu or select File -> Save to Database from the main menu bar. 
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Creating a New Cable 

Start the Component Wizard by selecting the New Component command as previously described. E³ 
activates the Database Editor mode and the Component Wizard is started, displaying the 
Identification page. 
 
Select the component type Cable. Enter the new component’s name (here Cable1) and its device 
letter code (here W). 
 
Since a completely new component is created, nothing is entered in the lower section of the dialog 
where a component can be defined whose structure is to be used. 
 

 
 
Click Next. 
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The Component Wizard’s Properties dialog is used to define the new component's master data. If the 
new component is based on an existing component, these fields will already contain entries. Since a 
completely new component is created in the example, these empty fields have to be filled. Select any 
properties for the new cable. 
 
For component attributes that are not displayed in the list, they can be added in the last line by simply 
clicking on the line and selecting the desired attribute from the drop-down list. These user-specific 
attributes, however, must be previously defined in the attributes table. 
This can be accomplished by using the Format → Attribute Names command in the Database Editor 
mode. 

 
 
After defining the component's master data, click Next. 
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The Component Wizard’s Cable Structure dialog appears next. The Completely new structure field 
is already active since a new structure for the cable is created. This definition cannot be changed. 
 
 
Enter the number of conductors as 4 in the example. If, at this point, the definitions are sufficient, 
exit the Component Wizard and the definitions will be written directly to the database.  
 

 
  

 
To complete the example, however, continue by clicking Next. 
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Finally, the Component Wizard allows you to save the new created cable directly to the database. The 
option Edit component graphically allows you to refine the cable definition even more. 
 
Select this option and click on Finish. 
 

 
  

 
 
 
 
E³.cable opens a sheet, on which the four conductors are displayed.  
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These conductors are completed by adding shielding. To do so, select the cable’s conductors to be 
shielded in the Database Editor’s Project Window and select the Add Shield command from the 
context menu displayed by right-clicking on the conductors. First, add a shield for conductors 1 to 4. 
Next, add a shield to conductors 1 and 2, and again to conductors 3 and 4. 
 

     
 
 
The results should look like the following: 
 

 
 
 

 
Using the Component Properties, attributes can now be assigned to the component itself, the cable 
ends, the conductors and the conductor ends. To do so, right-click on a conductor or shield in the 
drawing area and select the Component Properties… command from the displayed context menu or 
right-click on the component in the Project Window and select the Properties… command from the 
displayed context menu. 
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Optionally, it is possible to modify the conductors’ numbering and names. To do so, right-click in the 
drawing area and select the Conductor Assignment… command from the displayed context menu.  
Select a conductor and type in a new name or press F2 to rename the conductor. To assign an entry 

from the Translation Table, press F2 and click on the  button to select the translation table, for 
example to define language-dependent conductor colors. 
 

 
 

 
The new cable component is complete and can now be saved to the database and is available to all 
users. Select the File -> Save to Database command from the main menu bar or Save to Database 
from the context menu displayed upon right-clicking in the drawing area. 
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You now have learned to create components, connectors and cables in the database using the 
E³.series Database Editor. The Database Wizard helps to create these additional elements in the 
database, which can then be used immediately in the project. 
 

 
 
 

Enjoy working with 
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